helpf.pro
Регистрация
 0 
Распечатать

Форма ~ Как установить отбор в открываемой форме?

Код 1C v 8.х
 ФормаВыбораВидаРасчета = ПланыВидовРасчета.УдержанияОрганизаций.ПолучитьФормуВыбора("ФормаВыбора", ЭлементыФормы.Удержания, "дляДокументаРегистрацияРазовыхУдержаний");
ФормаВыбораВидаРасчета.Отбор.Ссылка.ВидСравнения = ВидСравнения.НеВСписке;
ФормаВыбораВидаРасчета.Отбор.Ссылка.Значение = СпВидовРасчета;
ФормаВыбораВидаРасчета.Отбор.Ссылка.Использование = ИСТИНА;
ФормаВыбораВидаРасчета.Открыть();
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 15348
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 3
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1C: Enterprise Development Tools 37
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С Предприятие что это? 7
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Посмотреть все результаты поиска похожих
Комментарии
ab
28.12.2011 14:52Комментарий: 1
ab
Была задача в том, чтоб при открытии формы выбора документов сразу ставить отбор, и чтоб результат выбора записывался в элемент.

Работает следующий код:
Код 1C v 8.х
 Процедура ДокументОплатыНачалоВыбора(Элемент, СтандартнаяОбработка)
Если Элемент.Значение <> Неопределено Тогда
Если ТипЗнч(Элемент.Значение) = Тип("ДокументСсылка.ПлатежноеПоручениеВходящее") Тогда
ФормаСписка = Документы.ПлатежноеПоручениеВходящее.ПолучитьФормуВыбора(,Элемент);
Иначе
ФормаСписка = Документы.ПлатежныйОрдерПоступлениеДенежныхСредств.ПолучитьФормуВыбора(,Элемент);
КонецЕсли;
ОтборФормы = ФормаСписка.Отбор;
ОтборФормы.Контрагент.ВидСравнения = ВидСравнения.Равно;
ОтборФормы.Контрагент.Значение = КомпенсирующийОрган;
ОтборФормы.Контрагент.Использование = Истина;
ФормаСписка.Открыть();
СтандартнаяОбработка = Ложь;
КонецЕсли;
КонецПроцедуры
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.