helpf.pro
Регистрация
 0 
Распечатать

Экспорт печатных форм и любых данных из 1С в BMP, JPEG, PCX, PDF, PNG и TIFF.

Оптимальным решением является установка Bullzip PDF Printer . После установки в системе появляется виртуальный принтер, с помощью которого можно "печатать" в файл pdf из любого приложения. Программа бесплатная, работает в терминале и имеет поддержку русского языка.
После установки, можно печатать напрямую используя код:
Код 1C v 8.х
 
//Таб - ТабличныйДокумент
//ИмяФайла – путь для сохранения файла PDF (например «D:\Torg12.pdf»)
Процедура СоздатьФайлПДФ(Таб, ИмяФайла)

Попытка
ПДФПринтер = Новый ComObject(«Bullzip.PDFPrinterSettings»);
ПДФПринтер.SetValue(«output», ИмяФайла);
ПДФПринтер.SetValue(«ShowSaveAS», «never»);
ПДФПринтер.SetValue(«ShowProgress», «no»);
ПДФПринтер.SetValue(«ShowProgressFinished», «no»);
ПДФПринтер.SetValue(«ShowSettings», «never»);
ПДФПринтер.SetValue(«ShowPDF», «no»);
ПДФПринтер.SetValue(«ConfirmOverwrite»,»no»);
ПДФПринтер.WriteSettings();
Таб.Автомасштаб = Истина;
Таб.ИмяПринтера = «Bullzip PDF Printer»;Таб.Напечатать(Истина);
PDFФайл = Новый Файл(ИмяФайла);

Пока НЕ PDFФайл.Существует() Цикл
ОбработкаПрерыванияПользователя();
КонецЦикла;

Исключение

Сообщить(ОписаниеОшибки());
Сообщить(«Скорее всего необходимо установить или переустановить «»Bullzip PDF Printer»);
КонецПопытки;
//устанавливаем принтер по умолчанию
Таб.ИмяПринтера = ПолучитьПринтерПоУмолчанию();
КонецПроцедуры

Здесь функция ПолучитьПринтерПоУмолчанию() нужна для того чтобы вернуть печатной форме принтер по умолчанию, т.к. если напечатать без предварительного просмотра то печать пойдет на виртуальный PDF принтер BullzipPDFPrinter.
Код 1C v 8.х
 //получаем принтер по умолчанию
Функция ПолучитьПринтерПоУмолчанию()

Скрипт = Новый ComObject(«MSScriptControl.ScriptControl»);
Скрипт.Language = «vbscript»;
Скрипт.AddCode(»
|Function GetDefaultPrinter()
|GetDefaultPrinter=vbNullString
|Set objWMIService=GetObject(«»winmgmts:»" _
|& «»{impersonationLevel=impersonate}!\\.\root\cimv2″»)
|Set colInstalledPrinters=objWMIService.ExecQuery _
|(«»S_elect * from Win32_Printer»")
|For Each objPrinter in colInstalledPrinters
|If objPrinter.Attributes and 4 Then
|GetDefaultPrinter=objPrinter.Name
|Exit For
|End If
|Next
|End Function»);
Возврат СокрЛП(Скрипт.run(«GetDefaultPrinter»));
КонецФункции



Печать в PDF используя bioPDF
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 23990
 0 
Распечатать
Возможно, вас также заинтересует
Вывести табличный документ в PDF 2
Данный пример работает на платформе выше 8.2.13 Макет = ПолучитьМакет(" Макет" ); ОбластьШапка = Макет.ПолучитьОбласть(" Шапка" ); ТабДок = Новый ТабличныйДокумент; ОбластьШапка.Параметры.НомерДок = Номер; ...
Выгрузка в PDF из 1С (Средствами OpenOffice) 0
Возникла задача отправлять счета почтой. PDFcreator не подошел поскольку не удалось вместить счет на одну страницу по ширине. Решил попробовать OpenOffice. Как сохранять в PDF нашел быстро, а вот как уместить счет на одну страницу...
Горячие клавиши 1С Пользователю [ Предприятие] 0
Основные команды: Интерфейс: F6 - переключение между формами рабочего стола F10 - переход в главное меню окна Alt+1 - переход на панель Разделов Alt+2 - переход на панель Навигации Alt+3 - переход на панель Действий Alt+9 -...
Горячие клавиши 1С Разработчику [ Конфигуратор ] 20
Основные команды: Кодирование: Ctrl+Пробел - вызов подсказки Ctrl+Q - вызов шаблона Ctrl+F1 - поиск в синтакс-помощнике Ctrl + L - удалить текущую строку Alt+Shift+F - отформатировать код Исследование: F12 - ставим курсор на...
Добавление поддержки нестандартного штрих-кода в обработке ПечатьЭтикеток 0
Обработка ПечатьЭтикеток использует компоненту " 1С:Печать штрихкодов" (доступную на диске ИТС) для печати штрих-кодов(далее ШК). Эта компонента поддерживает следующие типы штрих-кодов: EAN8, EAN13, EAN128, Code39, Code128. Что делать...
Посмотреть все результаты поиска похожих
Комментарии
df
19.12.2012 15:30Комментарий: 3
df
немного дополню:
1. После установки дистрибутива сам булзиповский принтер не устанавливается, и нигде нет inf-файла чтобы установить его вручную. Решается просто: берем любой ненужный установленный принтер и в свойствах меняем ему порт и драйвер на BullZip.
2. У меня не заработал пример пока я не вставил команду ПДФПринтер.SetPrinterName(<имя принтера>);
3. Полдня мучился, искал имена параметров для их установки в конструкции ПДФПринтер.SetValue(<имя параметра>,<значение параметра>); - решается так:
меняем в конфигураторе ПДФПринтер.SetValue("ShowSaveAS", "never"); на
ПДФПринтер.SetValue("ShowSaveAS", "always");
и когда выскочит окно с параметрами будет окошко где можно создавать профили, создаем, и вытаскиваем ini-файл по пути который там написан. вот для ленивых мой:
[PDF Printer]
output=<desktop>\<smarttitle>.tif
confirmoverwrite=no
appendifexists=no
rememberlastfilename=no
rememberlastfoldername=no
openfolder=no
showpdf=no
showsaveas=never
showsettings=never
suppresserrors=no
device=tiffg4
resx=150
resy=150
textalphabits=4
graphicsalphabits=4
author=
title=
subject=
keywords=
usedefaultauthor=no
usedefaulttitle=no
target=default
compatibilitylevel=1.5
zoom=fitall
format=
linearize=no
usethumbs=no
watermarktext=
watermarkfontsize=45
watermarkrotation=c2c
watermarkcolor=#D9D9D9
watermarkfontname=ARIAL.TTF
watermarkoutlinewidth=2
watermarklayer=top
watermarkverticalposition=center
watermarkhorizontalposition=center
watermarkverticaladjustment=
watermarkhorizontaladjustment=
mergefile=
mergeposition=bottom
superimpose=
superimposeresolution=
superimposelayer=bottom
ownerpassword=
userpassword=
keylength=128
permissions=
E_Migachev
02.04.2012 12:06Комментарий: 2
E_Migachev
PiterPen, в параметрах принтера указывается формат вывода
PiterPen
31.03.2012 16:55Комментарий: 1
PiterPen
А как выгрузить например в JPG ?
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.