helpf.pro
Регистрация
 0 
Распечатать

Заменить в строке пробелы на указанные символы

Код 1C v 8.х
 Функция ЗаменитьПробелы(Строка, Символы)
// Пишем все слова с больших букв, кому не надо закомментируйте
СтрокаВозврата = СокрЛП(ТРег(Строка));
// Удаляем пробелы
Если НЕ ПустаяСтрока(СтрокаВозврата) Тогда
СтрокаВозврата = СтрЗаменить(СтрокаВозврата, " ", Символы);
КонецЕсли;
Возврат СтрокаВозврата;
КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 15079
 0 
Распечатать
Возможно, вас также заинтересует
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
Активация открытой книги Excel для корректировки 0
Нужно было получить для изменения уже открытую книгу Excel, а если она закрыта, то открыть и изменять. Ниже код, который данную задачу решает. Попытка Эксель = Неопределено; Книга = Неопределено; Лист = Неопределено; ...
База 1С вылетает, виснет, не грузится, падает с ошибкой? 0
Есть ряд методов, которыми можно попытаться " поднять" упавшую базу 1С 8.х Но сперва нужно сделать резервную копию! Сделайте резервную копию простым копированием папки базы, выгрузка не всегда может быть корректна. ...
Ввод по строке - поиск по первым символам или в любом месте наименования 0
При разработке конфигурации, для упрощении ввода документов потребовалось настроить ввод номенклатуры по совпадению любой части наименования! В 1С 8.3 по умолчанию настройки справочника номенклатуры такие: При...
Посмотреть все результаты поиска похожих
Комментарии
dan7i
05.01.2015 08:37Комментарий: 5
dan7i

Вот еще небольшой фрагмент до кучи

//Нормализация пробелов (остаются только одинарные пробелы)

ЗначениеПоля = СокрЛП(ЗначениеПоля);

Пока ЗначениеПоля <> СтрЗаменить(ЗначениеПоля," "," ") Цикл ЗначениеПоля = СтрЗаменить(ЗначениеПоля," "," "); КонецЦикла;

dan7i
05.01.2015 08:36Комментарий: 4
dan7i

Вот еще небольшой фрагмент до кучи

//Нормализация пробелов (остаются только одинарные пробелы)

ЗначениеПоля = СокрЛП(ЗначениеПоля);

Пока ЗначениеПоля <> СтрЗаменить(ЗначениеПоля," "," ") Цикл ЗначениеПоля = СтрЗаменить(ЗначениеПоля," "," "); КонецЦикла;

PiterPen
01.03.2012 21:09Комментарий: 3
PiterPen
Часто приходится пробелы убирать. можно так.

Код 1C v 8.х
  Пока Найти(Стр," ")<>0 Цикл
Стр=СтрЗаменить(Стр," ","");
КонецЦикла;
E_Migachev
29.11.2009 21:46Комментарий: 2
E_Migachev
По сути ничем!
А проверка на пустую строку только для ускорения. Зачем обрабатывать пустую строку...
Valet
28.11.2009 09:47Комментарий: 1
Valet
А чем результат будет отличаться от этого - более короткого?
Зачем проверять на пустую строку?
Код 1C v 8.х
 
Функция ЗаменитьПробелы(Строка, Символы)
Возврат СтрЗаменить(СокрЛП(ТРег(Строка)), " ", Символы);
КонецФункции
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.