helpf.pro
Регистрация
 0 
Распечатать

Пример подключения к базе 1С 7.7 из 1С 8.0-8.1

Код 1C v 8.х
 // Переменная База - строка содержащая путь к базе 1С 7.7
// Возвращает переменную содержащую в себе COM-объект 1С 7.7
Функция ПодключитьсяКOLE(База)
Попытка
v7 = Новый COMObject("V1CEnterprise.Application");
Исключение
Сообщить(ОписаниеОшибки());
Возврат Null;
КонецПопытки;

Попытка
Открыта = v7.Initialize(v7.RMTrade, "/D""" + База+ """ /M ", "NO_SPLASH_SHOW");
Исключение
Сообщить(ОписаниеОшибки());
Возврат Null;
КонецПопытки;

Если Не Открыта Тогда
Сообщить(ОписаниеОшибки());
Возврат Null;
КонецЕсли;

Возврат v7;
КонецФункции


Экземпляр COM-объекта 1С 7.7 уничтожается (по завершению работы с ним) следующим образом:
Код 1C v 8.х
 v7 = "";   
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 22985
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Посмотреть все результаты поиска похожих
Комментарии
IKSparrow
15.01.2010 13:13Комментарий: 2
IKSparrow
Тоже гуд. Но я всегда стараюсь с такими вещами работать через:
Код 1C v 8.х
 Попытка
[...]
Исключение
[...]
КонецПопытки;

Чтобы была возможность обработки исключительных ситуациях - максимум автоматизации. Минимум интерактивного вмешательства.
E_Migachev
14.01.2010 12:58Комментарий: 1
E_Migachev
Хороший пример, вот еще несколько:

Пример получения данных в 8-ке из 7-ки запросом:

Код 1C v 8.х
 	V7 = Новый ComОбъект("V77s.Application");

Открыта = V7.Initialize(V7.RMTrade,"/d\\basa1c\Work","NO_SPLASH_SHOW");

Если Открыта Тогда

Запрос = V7.CreateObject("OdbcRecordSet");

ТЗ = "

|S_elect СпрТ.id [Элем $Справочник.Города]

|from $Справочник.Города СпрТ (nolock)

|where СпрТ.isMark = 0";

ТЗн = Запрос.ВыполнитьИнструкцию(ТЗ);

ТЗн.ВыбратьСтроки();

Пока ТЗн.ПолучитьСтроку()= 1 Цикл

Сообщить(ТЗн.Элем.Наименование+" "+Формат(Тзн.Элем.Код, "Ч(0)9.0"))

КонецЦикла

КонецЕсли;





Простой пример подключения

Код 1C v 8.х
 // в v 8.1 подключаюсь к семерочной базе

База= Новый COMObject("v77.Application");

Открыта=База.Initialize(Опер.RMTrade," /d"+Путь+" /N" + СокрЛП(Пользователь)+ " /P" +СокрЛП(Пароль),"");



СпрСотр = База.CreateObject("Справочник.Сотрудники");

Если СпрСотр.Выбрать("Укажите откуда берем остатки:") = 0 Тогда

Предупреждение("Не указано место остатков!");

Возврат;

КонецЕсли;

Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.