helpf.pro
Регистрация
 0 
Распечатать

Реквизит ~ Функция проверяет, все ли реквизиты элемента заполнены(Краткий вариант проверки)?

Код 1C v 8.х
 // Возвращаемое значение:
// Ложь ,если не все реквизиты заполнены
// Истина, если все отмеченные реквизиты заполнены

Функция ПроверитьНезаполненныеРеквизиты(Элементы) Экспорт
Для каждого стр Из Элементы Цикл
Если ТипЗнч(стр)=Тип("ПолеВвода") И стр.АвтоОтметкаНезаполненного И
НЕ ЗначениеЗаполнено(стр.Значение) Тогда
Если стр.Имя=стр.Подсказка Тогда
стрПодсказка="";
Иначе
стрПодсказка=" : "+стр.Подсказка;
КонецЕсли;
Возврат "Не заполнено поле "+стр.Имя+стрПодсказка;
КонецЕсли;
КонецЦикла;
Возврат "";
КонецФункции
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 13600
 0 
Распечатать
Возможно, вас также заинтересует
В отчет не попадают данные за последний день… Как исправить? 0
Пользователь выбрал период формирования отчета с 1июля по 31. Почему при формировании отчета в него не попадают данные за 31 число? На самом деле, это одна из самых распространенных ошибок при разработке отчетов. В 1С 8.х дата содержит время с точно
Ввод документа на основании - Программно 11
НовДок = Документы.ПеречислениеНДФЛвБюджет.СоздатьДокумент(); //Заполнить - вызывает ОбработкаЗаполнения(Основание) в документе ПеречислениеНДФЛвБюджет НовДок.Заполнить(ЭлементыФормы.ДокументСписок.ТекущаяСтрока); НовДок.ПолучитьФорму().Открыть()
Ввод записей в журнал расчетов 1
Добавление записи в журнал расчетов: Метод Новая может быть вызван где угодно, в глобальном модуле, модуле обработок, документов и т.д. Данный метод проверяет корректность заполненных реквизитов журнала расчетов. При вводе новых записей журнал
где в УТ 2.1 заполнить счета учета расчетов с контрагентами? 0
1с Предприятие Управление торговлей 2.1 Не проводится документ Поступление товаров и услуг. Ошибка - не заполнены оба счета. Не могу найти, где заполнить счета учета расчетов с контрагентами
Заполним "ТЗПолучатель" данными таблицы значений "ТЗИсходная" Краткий вариант 0
ТЗПолучатель = ТЗИсходная.Скопировать(); // или так Для Каждого СтрокаИсходнойТаблицы Из ИсходнаяТаблица Цикл НоваяСтрока = ТЗПолучатель.Добавить(); ЗаполнитьЗначенияСвойств(НоваяСтрока, СтрокаИсходнойТаблицы); КонецЦикла;
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.