helpf.pro
Регистрация
 0 
Распечатать

Функция выделяет из имени файла его расширение

Код 1C v 8.х
 
// Функция выделяет из имени файла его расширение
//
// Параметры
// ИмяФайла – Строка, содержащая имя файла, неважно с именем каталога или без.
//
// Возвращаемое значение:
// Строка – расширение файла.
//
Функция ПолучитьРасширениеФайла(ИмяФайла) Экспорт

ПозицияПоследнейТочки = 0;
РасширениеФайла = ИмяФайла;

Пока 1 = 1 Цикл

ПозицияПоследнейТочки = Найти(РасширениеФайла, ".");

Если ПозицияПоследнейТочки = 0 Тогда

Прервать;

Иначе

РасширениеФайла = Сред(РасширениеФайла, ПозицияПоследнейТочки + 1)

КонецЕсли;

КонецЦикла;

Возврат ?(РасширениеФайла = ИмяФайла, "", РасширениеФайла);

КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 8214
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1Cv8.1CD - Файл данных достиг максимального размера! 3
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Microsift Visual C++ Runtime Library Program ...1cv77s.exe abnormal program termination 0
При запуске 1С 7.7 выдает сообщение: Microsift Visual C++ Runtime Library Program C:Program Files1Cv77BIN1cv77s.exe abnormal program termination Вариант 1. Обычно это происходит, когда повреждается файл регистрации. Точнее, когда не дописывает
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.