helpf.pro
Регистрация
 0 
Распечатать

Функция, определяющая наличие числа в строке

Код 1C v 8.х
 Функция ЭтоЧисло(Строка) // Экспорт

РезультатЭтоЧисло = 1; // Истина

ДлинаСтроки = СтрДлина(Строка);

Для i = 1 По ДлинаСтроки Цикл

Символ = Лев(Строка, 1);
Строка = Сред(Строка, 2);

Если Не (Символ = "1" Или Символ = "2" Или Символ = "3" Или Символ = "4" Или Символ = "5" Или Символ = "6" Или Символ = "7" Или Символ = "8" Или Символ = "9" Или Символ = "0") Тогда
РезультатЭтоЧисло = 0; // Ложь
Прервать;
КонецЕсли;

КонецЦикла;

Возврат РезультатЭтоЧисло;

КонецФункции // ЭтоЧисло
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6253
 0 
Распечатать
Возможно, вас также заинтересует
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Комментарии
E_Migachev
29.03.2010 14:17Комментарий: 4
E_Migachev
Ioanngood, согласен, твой пример проще для понимания )
Выкладывай еще примеры *06
Ioanngood
29.03.2010 08:42Комментарий: 3
Ioanngood
E_Migachev, поместил в категорию Работа с Текстом (Строкой). )

Мне кажется, что мой пример проще для понимания, чем твой... *13
E_Migachev
26.03.2010 16:07Комментарий: 2
E_Migachev
Ioanngood, хороший пример, только может его нужно в категорию Работа с Текстом (Строкой), там кстати есть немного другой пример но похожий Функция проверяет наличие в строке только цифр.
Ioanngood
26.03.2010 15:49Комментарий: 1
Ioanngood
В принципе, это можно и проще:
Код 1C v 8.х
 Функция ЭтоЧисло(Строка) // Экспорт
Попытка
реквизитЧисло = Число(Строка);
РезультатЭтоЧисло = 1; // Истина
Исключение
РезультатЭтоЧисло = 0; // Ложь
КонецПопытки;

Возврат РезультатЭтоЧисло;

КонецФункции // ЭтоЧисло



Но тут возникает нюанс - это будет косячить, если будет структура типа:
Код 1C v 8.х
 Попытка
....
Попытка
...
Исключение
...
КонецПопытки;
Исключение
...
КонецПопытки;

Ибо два исключения 1С не допускает.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.