helpf.pro
Регистрация
 +1 
Распечатать

Функции преобразуют время из представления в виде строки в число и обратно

Код 1C v 8.х
 
//Функции преобразуют время из представления в виде строки в число и обратно
//
// Параметры:
// Время - Строка - Строковое представление времени 12:51
//
// Возвращаемое значение:
// Время - Число 5.2 - Время в виде числа
Функция ВремяСтрокаВЧисло(Время) Экспорт

Поз = Найти(Время,":");
Если НЕ Поз тогда
Возврат 0;
КонецЕсли;
ЦелЧасть = Число(Лев(Время,Поз-1));
ДробЧасть = Число(Сред(Время,Поз+1,6)) / 60;
Возврат ЦелЧасть + ДробЧасть;

КонецФункции

// Преобразует время из числового представления в строкове
Функция ВремяЧислоВСтрока(Время) Экспорт

ЦелЧасть = Цел(Время);
ДробЧасть = (Время - ЦелЧасть) * 60;
Возврат Строка(ЦелЧасть) + ":" + Строка(Окр(ДробЧасть,0));

КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 7456
 +1 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.