helpf.pro
Регистрация
 0 
Распечатать

Открыть форму выбора и выбрать элемент справочника

На форме отчета находится поле списка, связанное с реквизитом списком значений.
Нужно:
1) чтоб при нажатии на кнопку Подбор на форме отчета открывалась форма справочника
2) при выборе элементов этого справочника они попадали в список значений в форме отчета и отображались в поле списка.
Как это сделать?


Код 1C v 8.х
 // сзВодители - тот самый список значений,
// Справочники.Водители - справочник, откуда надо добавлять данные в список

// Кнопка Подбор:
Процедура ДобавитьВодителяНажатие(Элемент)
ФормаПодбора = Справочники.Водители.ПолучитьФормуСписка(,ЭтаФорма);
ФормаПодбора.РежимВыбора = Истина;
ФормаПодбора.ЗакрыватьПриВыборе = Ложь;
Если Не ФормаПодбора.Открыта() Тогда
ФормаПодбора.Открыть();
КонецЕсли;
КонецПроцедуры

// ОбработкаВыбора для формы со Списком Значений
Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
сзВодители.Добавить(ЗначениеВыбора, ЗначениеВыбора.Наименование, Истина);
КонецПроцедуры

Как видите, владельцем формы, открываемой для подбора служит не отдельный элемент формы отчета, а вся форма отчета.
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 12202
 0 
Распечатать
Возможно, вас также заинтересует
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Microsoft SQL Server Native Client Добавление значения в столбец "datetime" привело к переполнению 0
При формировании отчета на СКД получили ошибку: Microsoft SQL Server Native Client 11.0: Добавление значения в столбец "datetime" привело к переполнению Подробнее текст такой: ... по причине: Ошибка компоновки данных по причине: Ошибка...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Был ли изменен элемент справочника? 0
// Модифицированность() - Определяет, был ли изменен объект после считывания из базы данных. // НО Метод не позволяет определить, был ли изменен объект другими пользователями. Если Модифицированность() тогда ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.