helpf.pro
Регистрация
 0 
Распечатать

Как получить Имя Пользователя?

Код 1C v 8.2 УП
 &НаКлиенте
Процедура СообщитьИмяПользователя(Команда)
// Вставить содержимое обработчика.
Сообщить(ПолучитьПользователя());

КонецПроцедуры

&НаСервере
Функция ПолучитьПользователя()
Перем ВыбПользователь;
ВыбПользователь = ПользователиИнформационнойБазы.ТекущийПользователь();
Возврат ВыбПользователь.Имя;
КонецФункции;

// или так:
Сообщить(ИмяПользователя());
Сообщить(ПолноеИмяПользователя());



Код 1C v 8.х
 ИмяПользователя = ИмяПользователя();    
Если ПустаяСтрока(ИмяПользователя) Тогда
// пользователь не авторизовался
ИмяПользователя = "НеАвторизован";
Иначе
ИмяПользователя = ПолноеИмяПользователя();
КонецЕсли;



Код 1C v 7.x
 Сообщить(ИмяПользователя())
// Сообщит: ПупкинВася

Сообщить(ПолноеИмяПользователя())
// Сообщит: Пупкин Василий Петрович
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 32083
 0 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 40
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно использовать, когда требуется получ
1C и Google Maps 20
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во время решения задачи было реш
1C: Enterprise Development Tools 49
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С Предприятие что это? 11
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который выпускает компания 1С . Что такое
COM-подключение к базе 7.7 из .NET, .NET Core 0
Инсталяция: dotnet add package sabatex.V1C77 или добавить через NUGET пакет sabatex.V1C77. Добавить пространство имен: using sabatex.V1C77; пример использованя: ---C# static void Main(string args) { // создаем строку соединен
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.