helpf.pro
Регистрация
 -1 
Распечатать

1С 7.x : Как проверить целое число? Четное число?

Код 1C v 8.х
 Функция ЧетноеЧисло(пЧисло)    
Четное = пЧисло%2=0;
Возврат Четное;
КонецФункции


Код 1C v 8.х
 
Функция ровноеЧисло(пЧисло)
Четное = пЧисло%2=1;
Возврат Четное;
КонецФункции

//или

Фунция ДровноеЧисло (Чис)
Возврат Чис = Цел(Чис);
КонецФункции


Код 1C v 7.x
 Функция ДробноеЧисло (Чис)
Возврат ?(Чис = Цел(Чис),1,0);
КонецФункции
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 7732
 -1 
Распечатать
Возможно, вас также заинтересует
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Алгоритм шифрования RC4 0
Для решения некоторых задач, иногда требуется имееть возможность шифровать и дешифровывать, какие-то данные. Но при этом нет возможности использовать стороние внешнии компоненты. Предлагаем пример реализации...
Ввести значение, ввод значения 0
//Пример универсального ввода значения Перем ВыбЗнач; Массив = Новый Массив; Массив.Добавить(Тип("Число")); Массив.Добавить(Тип("Строка")); Массив.Добавить(Тип("Дата")); КЧ = Новый КвалификаторыЧисла(12,2); КС = Новый...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.