helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Запись движений Приход или Расход в регистр остатков

Методы ДвижениеПриход и ДвижениеРасход, доступны только при проведении документа в предопределенной процедуре ОбработкаПроведения.

Код 1C v 7.x
  ВыбратьСтроки(); //Переберем строки документа
Пока ПолучитьСтроку() > 0 Цикл
Регистр.ТовЗап.ПривязыватьСтроку(НомерСтроки); //Записать НомерСтроки документа в движении регистра.
Регистр.ТовЗап.ДвижениеПриход(Склад, Товар, Количество, Стоимость);
КонецЦикла;
//или
Процедура ОбработкаПроведения()
строк = КоличествоСтрок();
ВыбратьСтроки(); //Переберем строки документа
Пока ПолучитьСтроку()=1 Цикл
Сообщить("Склад=" + Склад + " Получатель=" + Получатель+ " Товар="+Товар+" кол-во="+Количество+" сумма="+Количество*Цена);
Регистр.Остатки_товаров.ДвижениеРасход(Товар,Склад,Получатель,Количество,Количество*Цена);
КонецЦикла;
КонецПроцедуры
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 6073
 0 
Распечатать
Возможно, вас также заинтересует
v7plus.dll - отсутствует CLSID либо отсутствует интерфейс llnitDone 0
При выгрузке отчетности в 1С 7.7 программа ругается на v7plus.dll и указывает, что отсутствует интерфейс llritDone. Что делать? 1) Поудалять нафиг все v7plus.dll из каталогов ИБ и папок пользователей 2) Оставить только в bin каталоге и...
Альтернативный перенос остатков между 7.7 и 8.1 (обработкой с ИТС ЗагрузкаДанныхИзТаблДокум) 0
Нашел альтернативный, практически моментальный способ переноса остатков между семерой и восьмерой (так и между восмерками). Не требуется никаких дополнительных усилий, программирования, писания обработок и т.д. и т.п....
Быстрый перенос списка баз с одного компьютера на другой 0
Для 8.1 : 1. Список баз 8.1 можно сохранять в файл.Для этого правой кнопкой мыши по корневому элементу " Информационные базы " , далее " Сохранить ссылку в файл " . 2. Получаем файл с расширением v8i , это текстовый файл в...
Ввод записей в журнал расчетов 0
Добавление записи в журнал расчетов: Метод Новая может быть вызван где угодно, в глобальном модуле, модуле обработок, документов и т.д. Данный метод проверяет корректность заполненных реквизитов журнала расчетов....
Выборка документа по номеру и вывод на Печать, в Табличный Документ 0
Процедура Печать() Если (ПустоеЗначение(ДатаНач)=1) или (ПустоеЗначение(ДатаКон)=1) Тогда Предупреждение(" Не задан период отчета" ); Возврат; КонецЕсли; Заг=" За период с " +ДатаНач+" по " +ДатаКон; Таб=СоздатьОбъект("...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.