helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Выбрать Итоги, остатки регистра

Код 1C v 7.x
 
// Пример 1
РегТовары = СоздатьОбъект("Регистр.Товары");
РегТовары.ВыбратьИтоги();
Пока РегТовары.ПолучитьИтог()=1 Цикл
Сообщить("Товар " + Строка(РегТовары.Товар) +
" на складе " + Строка(РегТовары.Склад) +
" кол-во: " + Строка(РегТовары.Количество) +
" стоимость: " + Строка(РегТовары.Стоимость) +
КонецЦикла;

// Пример 2
Процедура ВыбратьКредит()
Список = СоздатьОбъект("СписокЗначений");
Рег = СоздатьОбъект("Регистр.ТоварныйКредит");
Рег.УстановитьФильтр(Клиент, );
Рег.ВыбратьИтоги();
Ном = 0;
Пока Рег.ПолучитьИтог() = 1 Цикл
Док = Рег.Документ;
Список.ДобавитьЗначение(Док, "" + Док + " — Остаток = " + Рег.Долг);
Если Ном = 0 Тогда
ВыбДок = Док;
КонецЕсли;
Ном = Ном + 1;

КонецЦикла;
Если Ном > 0 Тогда
Если Список.ВыбратьЗначение(ВыбДок, "Выберите кредит") = 1 Тогда
ДокКредита = ВыбДок;
КонецЕсли;
КонецЕсли;
Возврат;
КонецПроцедуры
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 8577
 0 
Распечатать
Возможно, вас также заинтересует
Microsift Visual C++ Runtime Library Program ...1cv77s.exe abnormal program termination 0
При запуске 1С 7.7 выдает сообщение: Microsift Visual C++ Runtime Library Program C:Program Files1Cv77BIN1cv77s.exe abnormal program termination Вариант 1. Обычно это происходит, когда повреждается файл регистрации. Точнее, когда не дописывает
Альтернативный перенос остатков между 7.7 и 8.1 (обработкой с ИТС ЗагрузкаДанныхИзТаблДокум) 0
Нашел альтернативный, практически моментальный способ переноса остатков между семерой и восьмерой (так и между восмерками). Не требуется никаких дополнительных усилий, программирования, писания обработок и т.д. и т.п....
Ввод записей в журнал расчетов 0
Добавление записи в журнал расчетов: Метод Новая может быть вызван где угодно, в глобальном модуле, модуле обработок, документов и т.д. Данный метод проверяет корректность заполненных реквизитов журнала расчетов....
Временный расчет регистров 0
Временный расчет регистров требуется, если нужно выбрать итоги или движения на определенную дату. По умолчанию итоги регистров выдаются на Точку актуальности. Формулировка 1С - Метод ВременныйРасчет устанавливает...
Выбрать все движения регистра по датам 0
Рег1 = СоздатьОбъект(" Регистр.Взаиморасчеты" ); Если Режим = " Подробно" Тогда Рег1.УстановитьФильтр(Клиент); Рег1.ВыбратьДвижения(ДатаНачало, ); Пока Рег1.ПолучитьДвижение() 0 Цикл Док = Рег1.ТекущийДокумент(); ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.