helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Как узнать является ли строка числом?

Код 1C v 7.x
  
// Если передено число - то 1, иначе 0
Функция ЭтоЧисло(Знач ТекСтр)
ТекСтр = СокрЛП(ТекСтр);
ТекСтр = СтрЗаменить(ТекСтр,"0","9");

Если (СтрДлина(Число(ТекСтр)) <> СтрДлина(ТекСтр))
или ((СтрДлина(ТекСтр) = 1) и (Найти("0123456789",ТекСтр) = 0)) Тогда
Возврат 0;
КонецЕсли;

Возврат 1;
КонецФункции


Код 1C v 8.х
 
// Если передено число - то истина, иначе ложь
Функция ЯвляетсяЧислом(Значение) Экспорт
Если ТипЗнч(Значение) = Тип("Число") Тогда
Возврат Истина
Иначе
Если ТипЗнч(Значение) = Тип("Строка") Тогда
Если Значение = "" Тогда
Возврат Ложь;
КонецЕсли;
КонецЕсли;

Попытка
Р = Число(Значение);
Исключение
Возврат Ложь;
КонецПопытки;
Возврат Истина;
КонецЕсли;
КонецФункции
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 12715
 0 
Распечатать
Возможно, вас также заинтересует
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Microsift Visual C++ Runtime Library Program ...1cv77s.exe abnormal program termination 0
При запуске 1С 7.7 выдает сообщение: Microsift Visual C++ Runtime Library Program C:Program Files1Cv77BIN1cv77s.exe abnormal program termination Вариант 1. Обычно это происходит, когда повреждается файл регистрации. Точнее, когда не дописывает
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.