helpf.pro
Регистрация
 +1 
Распечатать

1С 7.x : Перебрать, выбрать элементы справочника

Код 1C v 8.х
 Выборка = Справочники.Сотрудники.Выбрать();
//или Выборка = Справочники.Сотрудники.ВыбратьИерархически();
Пока выборка.Следующий() = 1 Цикл
... //действия с очередным элементом
...Сообщить("Сотрудник " + выборка.Наименование);
КонецЦикла;

//А через запрос так:
Запрос = Новый Запрос("
|ВЫБРАТЬ
| Ссылка,
| Наименование
|ИЗ
| Справочник.Номенклатура
|АВТОУПОРЯДОЧИВАНИЕ");

Результат = Запрос.Выполнить().Выбрать();

Пока Результат.Следующий() Цикл
Наименование = Результат.Наименование;
КонецЦикла;


Код 1C v 7.x
 
// Обход элементов справочника
Спр = СоздатьОбъект("Справочник.Материалы");
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент() = 1 Цикл
// Дальнейшие действия с Спр.ТекущийЭлемент()
сообщить("Наименование "+спр.Наименование+" Код "+спр.код);
КонецЦикла;

//А через запрос так:
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса ="
|Период с Дата1 по Дата2;
|Обрабатывать НеПомеченныеНаУдаление;
|Спр = Справочник.Материалы.ТекущийЭлемент;
|Группировка Спр упорядочить по Спр.Наименование;";
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Предупреждение("Запрос по элементам справочника не выполнился!");
Возврат;
КонецЕсли;
// Теперь вся выборка находится в объекте "Запрос"
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 37721
 +1 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Ввод записей в журнал расчетов 0
Добавление записи в журнал расчетов: Метод Новая может быть вызван где угодно, в глобальном модуле, модуле обработок, документов и т.д. Данный метод проверяет корректность заполненных реквизитов журнала расчетов....
Выбор запросом элементов справочника и Загрузка в Документ 0
Запрос = СоздатьОбъект(" Запрос" ); ТекстЗапроса = " //{{ЗАПРОС(Сформировать) //|Период с ВыбНачПериода по ВыбКонПериода; |Обрабатывать НеПомеченныеНаУдаление; |Номенклатура = Справочник.Номенклатура.ТекущийЭлемент; ...
Выбрать все движения регистра по документу 0
Процедура Взаиморасчеты(ВыбКлиент, ДатаНачало, ДатаКонец) // Создание Таблицы для выходного отчета Заг = " Неизвестно." ; Таб = СоздатьОбъект(" Таблица" ); Клн = СоздатьОбъект(" Справочник.Клиенты" ); ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.