helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Выбрать, перебрать все элементы из определенной группы

В терминах 1С:Предприятия Группа - это Родитель
Код 1C v 8.х
 //ПолеВводаРодитель - поле на форме
Выборка = Справочники.Номенклатура.Выбрать(ПолеВводаРодитель);
Пока Выборка.Следующий() Цикл
Наименование = Выборка.Наименование;
КонецЦикла;

Запрос = Новый Запрос("
|ВЫБРАТЬ
| Ссылка,
| Наименование
|ИЗ
| Справочник.Номенклатура
|ГДЕ
| Родитель = &Родитель
|АВТОУПОРЯДОЧИВАНИЕ");

Запрос.УстановитьПараметр("Родитель", ПолеВводаРодитель);

Результат = Запрос.Выполнить().Выбрать();

Пока Результат.Следующий() Цикл
Наименование = Результат.Наименование;
КонецЦикла;


Выборка=Справочники.Номенклатура.ВыбратьИерархически(ПолеВводаРодитель);
Пока Выборка.Следующий() Цикл
Наименование = Выборка.Наименование;
КонецЦикла;


Запрос = Новый Запрос("
|ВЫБРАТЬ
| Ссылка,
| Наименование
|ИЗ
| Справочник.Номенклатура
|ГДЕ
| Родитель В ИЕРАРХИИ(&Родитель)
|АВТОУПОРЯДОЧИВАНИЕ");

Запрос.УстановитьПараметр("Родитель", ПолеВводаРодитель);

Результат = Запрос.Выполнить().Выбрать();

Пока Результат.Следующий() Цикл
Наименование = Результат.Наименование;
КонецЦикла;


Код 1C v 7.x
 спр=СоздатьОбъект("Справочник.Материалы");
спрГруппа=СоздатьОбъект("Справочник.Материалы");
спрГруппа.НайтиПоНаименованию("Топливо");
спр.ИспользоватьРодителя(спрГруппа.ТекущийЭлемент());
спр.ВыбратьЭлементы();
Пока спр.ПолучитьЭлемент()=1 Цикл
Сообщить(спр.ТекущийЭлемент().Наименование);
КонецЦикла;
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 19835
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Архивация баз 7.7 при помощи WinRara 0
Данный bat файл лежит в автозагрузке и при включении компьютера спрашивает о архивации. После нажатия пробела запускается архивация базы c:1CBasaOmegal1003 и в папке появляется архив Omegal_0110_2009.rar @echo off echo . echo . echo ...
Вхождение вида расчета в группу 0
Посчитаем все начисления текущего сотрудника за январь: // 1-й вариант: ВсегоНачислено = 0; ЖЗ.ВыбратьЗаписиПоОбъекту (ТекСотр, ДатаНач, ДатаКон); Пока ЖЗ.ПолучитьЗапись()=1 Цикл Если...
Выбрать все движения регистра по документу 0
Процедура Взаиморасчеты(ВыбКлиент, ДатаНачало, ДатаКонец) // Создание Таблицы для выходного отчета Заг = " Неизвестно." ; Таб = СоздатьОбъект(" Таблица" ); Клн = СоздатьОбъект(" Справочник.Клиенты" ); ...
Вывести справочник в таблицу, табличный документ 0
//Выведем весь справочник Номенклатура Запрос=новый Запрос; Запрос.Текст=" |ВЫБРАТЬ | Номенклатура.* |ИЗ | Справочник.Номенклатура КАК Номенклатура |" ; РезультатЗ = Запрос.Выполнить(); //Далее использовать функцию...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.