helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Периодические реквизиты справочника, только 1С v7

Чтение и запись периодических реквизитов.
Установка даты выборки периодических реквизитов для всего справочника.

Код 1C v 7.x
 //так мы узнаем, какая была у сотрудника
//категория на определенную дату
Катег = СпрСотр.Категория.Получить(НекаяДата);

//так мы установим сотруднику категорию
//на определенную дату
СпрСотр.Категория.Установить(НекаяДата, НоваяКатегория);

//можно установить дату выборки периодических
//реквизитов для всего справочника
СпрСотр.ИспользоватьДату(НекаяДата);

//тогда ниже уже нельзя использовать Установить и Получить
//доступ к периодическим реквизитам становится
//такой же, как к обычным реквизитам
Категор = СпрСотр.Категория;
СпрСотр.Оклад = 100;


В 8-ой версии нет периодических реквизитов. Вместо них необходимо использовать регистры сведений, развернутые во времени.
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 10476
 0 
Распечатать
Возможно, вас также заинтересует
Ввод записей в журнал расчетов 0
Добавление записи в журнал расчетов: Метод Новая может быть вызван где угодно, в глобальном модуле, модуле обработок, документов и т.д. Данный метод проверяет корректность заполненных реквизитов журнала расчетов....
Выгрузка / Загрузка данных посредством текстовых (TXT) файлов 2
Для работы с текстовыми документами существуют три типа данных – ТекстовыйДокумент, ЗаписьТекста и ЧтениеТекста . Разница двух подходов состоит в способе загрузки документа: ТекстовыйДокумент загружает файл...
Как получить список реквизитов операции и проводок? 0
// Пример 1 Для к = 1 по Метаданные.РеквизитПроводки() Сообщить(Метаданные.РеквизитПроводки(к).Идентификатор); КонецЦикла; // Пример 2 СписокРеквизитов = СоздатьОбъект(" СписокЗначений" ); // реквизиты формы операции ...
Недокументированные возможности функции Шаблон 0
// Присвоить значение переменной по ее имени. // в глоб.модуль: Функция Присвоить(Чему,Что) Экспорт Чему = Что; Возврат ""; КонецФункции // варианты вызова: // Шаблон(" "); // Шаблон(" "); // Пример: пусть у нас на форме есть 5...
Перебор Основных Реквизитов формы 0
//Перебор Основных Реквизитов формы Для Каждого Рек из ЭтаФорма.Метаданные().Реквизиты Цикл Сообщить(рек.Имя+" - " +рек.Синоним+" - " +Строка(рек.Тип)); КонецЦикла; // или так Для Каждого Рек из Метаданные().Реквизиты Цикл ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.