helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Как извлечь корень квадратный из числа

В 1С 8.х есть встроенная функция:
sqrt(аргумент);
Возвращает квадратный корень аргумента.
* аргумент: число
Код 1C v 8.х
 //Вычислить квадратный корень числа.
Результат = sqrt(169);
//Результат = 13

А если вспомнить школьную математику )
Корень квадратный из числа - это есть число возведённое в степень 1/2, соответственно:
Код 1C v 8.х
 Корень = POW(ДанноеЧисло, 0.5);   




Код 1C v 7.x
 
Функция Корень(Основание,Степень)
Если Степень = 1 Тогда
Возврат(Основание);
КонецЕсли;
Факториал = 1; Степень_ = 1; Сум = 0;
СтепеньЕ = 1/Степень*Лог(Основание);
Для ии = 1 по 28 Цикл
Факториал = Факториал * ии;
Степень_ = Степень_ * СтепеньЕ;
Сум = Сум + Степень_/Факториал
КонецЦикла;
Возврат(1+Сум);
КонецФункции

// КвaдpaтныйКopeнь(Apгумeнт)
// Пapaмeтpы:
// Apгумeнт - нeoтpицaтeльнoe чиcлo
// Boзвpaщaeмoe Значeниe:
// Квaдpaтный кopeнь Apгумeнтa
//
// Oпиcaниe
// ПpeднaЗначeнa для иcчиcлeния квaдpaтнoгo кopня чиcлa c
// пpимeнeниeм итepaциoннoгo мeтoдa Hьютoнa
// Итepaции выПолняютcя дo дocтижeния тoчнocти, зaдaннoй
// внeшнeй (публичнoй) Перемeннoй ДocтaтoчнaяToчнocть
Функция КвaдpaтныйКopeнь(Apгумeнт)
// Oгpaничимcя oблacтью oпpeдeлeния функции
Если Apгумeнт<0 Тогда
// cooбщeниe oб oшибкe
Сообщить("...","!");
Возврат ПолучитьПустоеЗначение();
// Oтceчeм нoль
ИначеЕсли Apгумeнт=0 Тогда
Возврат 0;
КонецЕсли;
// Bыбepeм пepвoe пpиближeниe
ПpeдыдущaяИтepaция = Apгумeнт/2;
Для Cч=1 По КoличecтвoИтepaций Цикл
Значeниe = 0.5*(ПpeдыдущaяИтepaция+
Apгумeнт/ПpeдыдущaяИтepaция);
Если Значeниe<ПpeдыдущaяИтepaция Тогда
Paзницa = ПpeдыдущaяИтepaция-Значeниe;
Иначе
Paзницa = Значeниe-ПpeдыдущaяИтepaция;
КонецЕсли;
Если Paзницa<ДocтaтoчнaяToчнocть Тогда
Прервать;
КонецЕсли;
ПpeдыдущaяИтepaция=Значeниe;
КонецЦикла;
Значeниe = Окр(Значeниe,Макс(КoличecтвoЗнaкoв-Лог10(Значeниe),0));
Возврат Значeниe;
КонецФункции
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 8939
 0 
Распечатать
Возможно, вас также заинтересует
Выгрузка / Загрузка данных посредством XML файлов? 0
В основе работы с XML-файлами лежит технология доступа SAX, которая осуществляет считывание по одному тегу. Для этого существует два типа данных – ЗаписьXML и ЧтениеXML . Запись данных справочника в XML-файл: Запись = Новый...
КД: Передача параметров из выгрузки в загрузку (в т.ч. и на ранние стадии) при обмене из 7.7 в 8.х 0
Кратко суть проблемы можно озвучить цитатой из документации: "Передача параметра из источника в приемник доступна только при обмене между информационными базами на платформе 1С:Предприятие 8". Ниже излагается...
Функции - Экспонента, Степень, Логарифм, Синус, Косинус, Тангенс 0
Встроенные функции 1С 8.х для работы со значениями типа Число: // Функция вычислет степень числа // _База - Число - Число, возводимое в степень // _Степ - Число - Степень числа Функция Степень(_База, _Степ) ..
Функция возведения числа в степень, в дробную степень 0
Для возведения числа в степень в 1С 8.х есть встроенная функция pow(основание, степень); Возвращает результат возведения основания в указанную степень. * основание: число * степень: число //Возведем число 5 в степень 3 ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.