helpf.pro
Регистрация
 +2 
Распечатать

1С 8.x : Найти значение в Таблице Значений

Пример поиска НАЙТИ:
Код 1C v 8.х
 //Искать по всей таблице значений
НайденнаяСтрока = ТаблицаЗначений.Найти(ИскомоеЗначение);

//Искать в колонках Поставщик, Покупатель
НайденнаяСтрока = ТаблицаЗначений.Найти(ИскомоеЗначение, "Поставщик, Покупатель");

//еще
НайденнаяСтрока = ТаблицаЦен.Найти(ВыбТовар, "Товар");
Если НайденнаяСтрока = Неопределено Тогда
Предупреждение("Товар не найден!");
Иначе
ЦенаТовара = НайденнаяСтрока.Цена;
КонецЕсли;


Пример поиска НАЙТИСТРОКИ:
Код 1C v 8.х
 // Сформировать структуру отбора. 
СтруктураПоиска = Структура("Сотрудник", ИскомоеЗначение);
// Найти строки.
МассивНайденныхСтрок = ТаблицаЗначений.НайтиСтроки(СтруктураПоиска);

// .... ИЛИ
НайдСтроки = тзСхемы.НайтиСтроки(Новый Структура("Доставка", ОформлениеСтроки.ДанныеСтроки.Ссылка));
Если НайдСтроки.Количество() > 0 Тогда
ОформлениеСтроки.Ячейки.Схема.УстановитьТекст(НайдСтроки[0].Схема);
Иначе
ОформлениеСтроки.Ячейки.Схема.УстановитьТекст("Нет");
КонецЕсли;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 33079
 +2 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Google maps, поиск оптимального маршрута 2
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; *...
Посмотреть все результаты поиска похожих
Комментарии
khanov_ildar
21.04.2016 13:33Комментарий: 1
khanov_ildar

А если мне надо наложить отбор по списку групп как быть? вот код который работает сейчас: Процедура ВынестиКонтрактВЗаявку(СтрокаДокументы, Контракт, ТПКод, Коррекция)

Отбор = Новый Структура("ИдДокумента", СтрокаДокументы.Ид); // Новый отбор, т.к. товар мог уйти на другую организацию

СтрокиДокумента = ТоварыДокумент.НайтиСтроки(Отбор);

ПозицийВсего = СтрокиДокумента.Количество();

Отбор.Вставить("ГлавныйРодитель", Контракт);

СтрокиКонтракта = ТоварыДокумент.НайтиСтроки(Отбор);

ПозицийКонтракта = СтрокиКонтракта.Количество();А вот если посылать Контракт как список папок то не работает такой отбор и как тут быть?

Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.