helpf.pro
Регистрация
 -1 
Распечатать

1С 8.x : Как проверить целое число? Четное число?

Код 1C v 8.х
 Функция ЧетноеЧисло(пЧисло)    
Четное = пЧисло%2=0;
Возврат Четное;
КонецФункции


Код 1C v 8.х
 
Функция ровноеЧисло(пЧисло)
Четное = пЧисло%2=1;
Возврат Четное;
КонецФункции

//или

Фунция ДровноеЧисло (Чис)
Возврат Чис = Цел(Чис);
КонецФункции


Код 1C v 7.x
 Функция ДробноеЧисло (Чис)
Возврат ?(Чис = Цел(Чис),1,0);
КонецФункции
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 8740
 -1 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 3
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
QR код в 1С 12
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.