helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Перевод из Десятичного в Двоичное и обратно

При разработке конфигураций, особенно если это обмен с сайтами или старыми системами учета, приходится переводить числа из одной системы исчисления в другую. Ниже примеры кода позволяющие выполнить данные функции перевода Десятичное в Двоичное и Двоичное в Десятичное:

Код 1C v 8.х
 Функция ДесятичноеВДвоичное(Знач ИсхЧисло) Экспорт
    
    ДвоичныйКод = "";
    Пока ИсхЧисло <> 0 Цикл
        ДвоичныйКод = "" + ИсхЧисло%2 + ДвоичныйКод ;
        ИсхЧисло = Цел(ИсхЧисло/2);
КонецЦикла;

    Возврат ДвоичныйКод;
    
КонецФункции

Функция ДвоичноеВДесятичное(Знач Стр2) Экспорт

Стр = СокрЛП(Стр2);
Рез=0;

Для н=1 по СтрДлина(Стр) Цикл
Рез=Рез*2+Число(Сред(Стр,н,1));
КонецЦикла;

Возврат Рез;

КонецФункции
Разместил:   Версии: | 8.x | 8.3 |  Дата:   Прочитано: 3191
 0 
Распечатать
Возможно, вас также заинтересует
Функция переводит Десятичное число в Шестнадцатеричное и обратно 2
// Функция переводит десятичное число в шестнадцатеричное // Параметры: _Число - Число - Десятичное число // Возвращаемое значение: Строка - Шестнадцатеричное число // Функция DecToHex(Знач _Число) База = 16; ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.