helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Массив ~ Функция ищет элемент в массиве. Если находит - возвращает его индекс, иначе -1

Код 1C v 8.х
 Функция ВернутьИндексВМассиве(МассивДанные, Элемент) Экспорт 

Если МассивДанные = Неопределено Тогда
Возврат -1;
КонецЕсли;

Для ИндексЭлемента = 0 По МассивДанные.ВГраница() Цикл

Если (МассивДанные[ИндексЭлемента] = Элемент) Тогда
Возврат ИндексЭлемента;
КонецЕсли;

КонецЦикла;

// не нашли элемент
Возврат -1;

КонецФункции
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 16349
 0 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 12
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1C медленно работает по сети с базой на SQL Server 13
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 5
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 30
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.