helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Функция проверки наличия только русских букв в строке допускаются пробелы и дефис и спецсимволы

Код 1C v 8.х
  Функция СтрокаНаписанаПоРусски(Знач СтрокаПараметр) Экспорт
СтрокаПараметр = СокрЛП(СтрокаПараметр);
СписокДопустимыхЗначений = Новый СписокЗначений;
СписокДопустимыхЗначений.Добавить(184);
СписокДопустимыхЗначений.Добавить(168);
СписокДопустимыхЗначений.Добавить(45);
СписокДопустимыхЗначений.Добавить(46);
СписокДопустимыхЗначений.Добавить(32);
СписокДопустимыхЗначений.Добавить(48);
СписокДопустимыхЗначений.Добавить(49);
СписокДопустимыхЗначений.Добавить(50);
СписокДопустимыхЗначений.Добавить(51);
СписокДопустимыхЗначений.Добавить(52);
СписокДопустимыхЗначений.Добавить(53);
СписокДопустимыхЗначений.Добавить(54);
СписокДопустимыхЗначений.Добавить(55);
СписокДопустимыхЗначений.Добавить(56);
СписокДопустимыхЗначений.Добавить(57);
Для Сч=1 По СтрДлина(СтрокаПараметр) Цикл
Код = КодСимвола(СтрокаПараметр,Сч);
Если (Код<192) И (СписокДопустимыхЗначений.НайтиПоЗначению(Код) = Неопределено) Тогда
Возврат Ложь;
КонецЕсли;
КонецЦикла;
Возврат Истина;
КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 5809
 0 
Распечатать
Возможно, вас также заинтересует
ДеревоЗначений в ТекстовыйДокумент 2
// Выводит данные ДереваЗначений в ТекстовыйДокумент, пригодный к рассмотрению в отладчике, окне сообщений и показу. // // Параметры: // рВетка - дерево значений, подлежащее выводу. Может иметь почти любую глубину...
Загрузка данных из CSV файла 1
// выберем CSV файл ДиалогВыбора = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие); ДиалогВыбора.Заголовок = “Выберите файл”; Если ДиалогВыбора.Выбрать() Тогда ИмяФайла = ДиалогВыбора.ПолноеИмяФайла; ...
Заменить в строке пробелы на указанные символы 0
Функция ЗаменитьПробелы(Строка, Символы) // Пишем все слова с больших букв, кому не надо закомментируйте СтрокаВозврата = СокрЛП(ТРег(Строка)); // Удаляем пробелы Если НЕ ПустаяСтрока(СтрокаВозврата) Тогда ...
Импорт в 1С из текстовых файлов (TXT, CSV) 3
Не редко возникает необходимость загрузить в справочники или документы 1С данные из текстового файла. Приведенный пример внешней обработки позволит преобразовать текстовый файл с известным разделителем данных в...
Как в 1C загрузить из Word текст? 2
Как в 1C из Microsoft Office Word 2007 внести текст? Код получения текста из файла word: Wk = Новый COMОбъект(" Word.Application" ); //Покажем открываемый документ Wk.Visible = Истина; Wk.Documents.Open(" D:file.doc" ); Документ = Wk.Active
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.