helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Поклеточный обход, перебор Таблицы Значений

Возможные варианты обхода:

Код 1C v 8.х
 //Во всех примерах ТЗПример - обрабатываемая Таблица значений

//Пример 1
Для каждого СтрТЗ из ТЗПример Цикл
Для каждого КолТЗ из ТЗПример.Колонки Цикл
//...
КонецЦикла;
КонецЦикла;

// Пример 2
Для стр = 0 По ТЗПример.Количество() Цикл
Для кол = 0 По ТЗПример.Колонки.Количество() Цикл
//...
КонецЦикла;
КонецЦикла;

//Пример 3
Для каждого СтрТЗ из ТЗПример Цикл
Для кол = 0 По ТЗПример.Колонки.Количество() Цикл
Сообщить(СтрТЗ[кол]);
КонецЦикла;
КонецЦикла;


При обработке Таблицы значений в 16 колонок и 500 строк - Разница в скорости выполнения между методами составила 3 секунды в пользу Примера № 3 (тестировал IKSparrow )

Тема обсуждения в Вопросах Поклеточный обход таблицы значений - что быстрее работает?
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 19909
 0 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 6
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1Cv8.1CD - Файл данных достиг максимального размера! 4
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
COM-подключение к базе 7.7 из 8.2 1С 5
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.