helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Как получить текущее время с милисекундами?

В Платформе 8.2.17 реализована возможность получения числа миллисекунд, прошедших с 1 января 0001 года, 0:00:00 UTC с помощью функции
Код 1C v 8.2 УП
 ТекущаяУниверсальнаяДатаВМиллисекундах()    


Код 1C v 8.х
  // В 8.х переменные типа "дата" содержат миллисекунды, только это нигде не написано
ДатаИсх = ТекущаяДата(); //простая дата+время
ДатаНов = ДатаИсх + 0.567; //дата+время+миллисекунды
Миллисекунды = (ДатаНов - ДатаИсх) * 1000; //вытаскиваем миллисекунды из даты


Код 1C v 8.х
 Функция ПолучитьТекущееВремяВМиллисекундах() Экспорт
Если JavaScript = Неопределено Тогда
Попытка
JavaScript = Новый COMОбъект("MSScriptControl.ScriptControl");
Исключение
Сообщить(ОписаниеОшибки(), СтатусСообщения.Внимание);
Возврат 0;
КонецПопытки;
JavaScript.Language = "javascript";
КонецЕсли;
Время = JavaScript.Eval("new Date().getTime()");
Возврат Время;
КонецФункции

Код 1C v 8.х
 // Как быстрее получить время в миллисекундах? 
Locator = Новый COMОбъект("WbemScripting.SWbemLocator");
ServicesSet = Locator.ConnectServer(".");
Для а=1 по 100 цикл
pEnum = ServicesSet.InstancesOf("Win32_OperatingSystem");
Для каждого Object Из pEnum Цикл
сообщить(сред(Object.LocalDateTime,13,6));
Прервать;
КонецЦикла;
КонецЦикла;



Код 1C v 7.x
 
Scr=СоздатьОбъект("MSScriptControl.ScriptControl");
Scr.Language = "javascript";
d=Scr.Eval("new Date();");
Сообщить(d.getTime(0));
Сообщить(d.getHours(0));
Сообщить(d.getMinutes(0));
Сообщить(d.getSeconds(0));
Сообщить(d.getMilliseconds(0));
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 19463
 0 
Распечатать
Возможно, вас также заинтересует
Деноминация 2016 в 1С 0
Чтобы провести деноминацию в 1С на 1 июля 2016 года, нужно учесть, что желательно учёт вести в двух суммовых измерениях в белорусских рублях старого и нового образца.
Как в периодическом независимом регистре сведений удалить все записи по валютам с наименованиями? 0
Как в периодическом независимом регистре сведений «КурсыВалют» удалить все записи по валютам с наименованиями «EUR» и «USD», период которых меньше 01 января 2005 года? Сначала получим таблицу записей, которые необходимо...
Как поменять период у записей периодического независимого регистра, соответствующих ряду условий? 0
В периодическом независимом регистре сведений ОтветственныеЛицаОрганизации все записи, касающиеся организации с наименованием Групп-трейдинг, период которых меньше 01 января 2005 года, необходимо перенести на 01...
Как указать нужную,конкретную дату? 1
Значения данного типа содержит дату григорианского календаря (с 01 января 0001 года) и время с точностью до секунды. Литералы: Строка цифр, заключенная в одинарные кавычки вида: ГГГГММДДччммсс, где: ГГГГ - четыре цифры...
Перенумерация документов, справочников 4
Восстановить нумерацию документов или справочников нам поможет специальная обработка «Универсальные подбор и обработка объектов». Эту обработку можно найти на диске ИТС (УниверсальныеПодборИОбработкаОбъектов.epf). ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.