helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Как реализовать метод красного сторно для регистра бухгалтерии?

Код 1C v 8.х
 Процедура ОбработкаПроведения(Отказ, Режим) 

СторнируемыеДвижения = РегистрыБухгалтерии.Хозрасчетный.ВыбратьПоРегистратору(СторнируемыйДокумент);

Пока СторнируемыеДвижения.Следующий() Цикл
Проводка = Движения.Хозрасчетный.Добавить();
Проводка.Период = Дата;
Проводка.СчетДт = СторнируемыеДвижения.СчетДт;
Проводка.СчетКт = СторнируемыеДвижения.СчетКт;

Для каждого Субконто Из СторнируемыеДвижения.СубконтоДт Цикл
Проводка.СубконтоДт[Субконто.Ключ] = Субконто.Значение;
КонецЦикла;

Для каждого Субконто Из СторнируемыеДвижения.СубконтоКт Цикл
Проводка.СубконтоКт[Субконто.Ключ] = Субконто.Значение;
КонецЦикла;

Проводка.ВалютаДт = СторнируемыеДвижения.ВалютаДт;
Проводка.ВалютаКт = СторнируемыеДвижения.ВалютаКт;
Проводка.ВалютнаяСуммаДт = - СторнируемыеДвижения.ВалютнаяСуммаДт;
Проводка.ВалютнаяСуммаКт = - СторнируемыеДвижения.ВалютнаяСуммаКт;
Проводка.КоличествоДт = - СторнируемыеДвижения.КоличествоДт;
Проводка.КоличествоКт = - СторнируемыеДвижения.КоличествоКт;
Проводка.НомерЖурнала = СторнируемыеДвижения.НомерЖурнала;
Проводка.Организация = СторнируемыеДвижения.Организация;
Проводка.Содержание = СторнируемыеДвижения.Содержание;
Проводка.Сумма = - СторнируемыеДвижения.Сумма;
КонецЦикла;

Движения.Хозрасчетный.Записать();

КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 7622
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Блокировка записей, невозможно изменить или удалить из регистра. Конфликт блокировок MS SQL + 1C 1
При попытке удалить запись из регистра сведений - получаю ошибку: она заблокирована, ошибка блокировок и т.д. Отключил всех пользователей, перезапустил сервер, пробую удалить - опять ошибка блокировки :( Путем тестов...
Ввод документа на основании - Программно 5
НовДок = Документы.ПеречислениеНДФЛвБюджет.СоздатьДокумент(); //Заполнить - вызывает ОбработкаЗаполнения(Основание) в документе ПеречислениеНДФЛвБюджет ...
Взаимодействие с Контрольно-Кассовыми Машинами (ККМ) 0
Имеется ли возможность взаимодействия конфигурации Управление торговлей с контрольно-кассовыми машинами (ККМ)? Данная возможность реализована в конфигурации в трех вариантах: ККМ в режиме фискального...
Внешние обработки, печатные формы, обработки по заполнению табличных частей 2
Справочник «Внешние обработки, печатные формы, обработки по заполнению табличных частей» содержит список произвольных обработок, произвольных отчетов, дополнительных печатных форм, обработок для заполнения ТЧ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.