helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Функция предназначена для получения имени элемента перечисления по значению

Код 1C v 8.х
 
// Предназначена для получения имени элемента перечисления по значению.
//
// Параметры:
// Элемент перечисления.
//
// Возвращаемое значение:
// Строка - имя элемента перечисления в метаданных.
//
Функция ПолучитьИмяЭлементаПеречисленияПоЗначению(ЗначениеПеречисления) Экспорт

ИмяЭлемента = Строка(ЗначениеПеречисления);
Для каждого ЭлементПеречисления Из Метаданные.Перечисления[ЗначениеПеречисления.Метаданные().Имя].ЗначенияПеречисления Цикл
Если ЭлементПеречисления.Синоним = Строка(ЗначениеПеречисления) Тогда
ИмяЭлемента = ЭлементПеречисления.Имя;
Прервать;
КонецЕсли;
КонецЦикла;

Возврат ИмяЭлемента;

КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6001
 0 
Распечатать
Возможно, вас также заинтересует
Авто добавление обработки в справочник Внешних обработок 0
Чтобы не изменять типовую конфигурацию приходится использовать типовой механизм внешних печатных форм и обработок. Данный код проверяет - добавлена ли открываемая обработка в конфигурацию, если нет - задает вопрос и...
Ввести перечисление, выбор перечисления 1
// В 8-ой версии нет такой фунции, но можно сделать так: ЗначПер=Перечисления.Важность.Средняя; //Установим перечисление предлагаемое выбрать по умолчанию Если ВвестиЗначение(ЗначПер,"Выберите важность:") тогда ...
Временные таблицы, что из себя представляют и как с ними работать? 5
Временные таблицы - хранятся на сервере и позволяют писать более простые запросы. Временные таблицы хранятся в объекте типа МенеджерВременныхТаблиц . Когда этот объект уничтожается, уничтожаются и временные...
Выборка (перебор) элементов справочника 0
// Выбрать( , , , ) Номенклатура = Справочники.Номенклатура; Отбор = Новый Структура("ТипНоменклатуры"); Пусто = Перечисления.ТипыНоменклатуры.ПустаяСсылка(); Отбор.ТипНоменклатуры = Пусто; Выборка =...
Выбрать движения, получить выборку записей регистра накопления 0
Пример 1 : //Взаиморасчеты за период, хотя, это лучше выбирать запросом , он в примере 3 Отбор = Новый Структура("Организация", Организация); НаборЗаписей =...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.