helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Как для Выбора Покупателя Открыть Справочник контрагенты с открытой группой Покупатели?

Код 1C v 8.х
  // Это событие для ячейки Контрагент Табличной части
Процедура КонтрагентНачалоВыбора(Элемент, СтандартнаяОбработка)

Если Элемент.Значение.Пустая() Тогда
СтандартнаяОбработка = Ложь;
ФормаВыбора = Справочники.Контрагенты.ПолучитьФормуВыбора( , Элемент);
ФормаВыбора.ВыборПокупателя = Истина;
ФормаВыбора.Открыть();
КонецЕсли;

КонецПроцедуры


// Это добавляем в ФОРМУ ВЫБОРА

//Получение группы из константы
Если ВыборПокупателя Тогда
ЭлементыФормы.СправочникСписок.ИерархическийПросмотр = Истина;
ЭлементыФормы.СправочникСписок.ТекущийРодитель = Константы.ГруппаПокупатели.Получить();
КонецЕсли;

//Указание группы как предопределенного элемента
Если ВыборПокупателя Тогда
ЭлементыФормы.СправочникСписок.ИерархическийПросмотр = Истина;
ЭлементыФормы.СправочникСписок.ТекущийРодитель = Справочники.Контрагенты.Покупатели;
КонецЕсли;
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 15491
 0 
Распечатать
Возможно, вас также заинтересует
Активация открытой книги Excel для корректировки 0
Нужно было получить для изменения уже открытую книгу Excel, а если она закрыта, то открыть и изменять. Ниже код, который данную задачу решает. Попытка Эксель = Неопределено; Книга = Неопределено; Лист = Неопределено; Состояние(" Выполняется
Использование Web-сервисов для синхронизации баз данных в режиме online 1с 8.х 11
Часто при ведении учета в различных конфигурациях 1с возникает необходимость выполнения обмена данных. Для решения этой задачи принято использовать Универсальный обмен данными XML или другие внешние обработки, общим у которых является использование
Как для Выбора Элемента Справочника Открыть Форму Выбора с нужной Открытой Группой? 6
Порядок действий такой: 1. В поле ввода " Номенклатура" добавь событие ПриНачалеВыбора. 2. Установи в них СтандартнаяОбработка = Ложь; 3. Получи форму выбора нужного справочника 4. Установи отбор по родителю 5. Открой форму для выбора Теп
Как для Подбора Элемента Справочника Открыть Форму Подбора с нужной Открытой Группой? 0
В продолжении Как для Выбора Элемента Справочника Открыть Форму Выбора с нужной Открытой Группой? опишу как настроить Подбор, на примере Типовой Бухгалтерии: 1. Откроем документ Реализации и зайдем в Свойства Кнопки Подбор https://helpf.pro/up
Открыть форму документа 0
Форма = Документы.РасходныйКассовыйОрдер.ПолучитьФорму(); //возможные варианты получения формы: Параметы () //Форма = Документы.РасходныйКассовыйОрдер.ПолучитьФормуВыбора(); //Форма = Документы.РасходныйКассовыйОрдер.ПолучитьФормуНовогоДокумент
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.