helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Массив ~ Функция сравнивает два массива однотипных значений

Код 1C v 8.х
 
// Сравнивает два массива однотипных значений (кроме коллекций значений)
//
// Параметры:
// ПервыйМассив,ВторойМассив - сравниваемые массивы
//
// Возвращаемое значение:
// булево.
//
Функция МассивыИдентичны(ПервыйМассив,ВторойМассив) Экспорт

ЭлементовМассива = ПервыйМассив.Количество();
МассивыСовпадают = (ЭлементовМассива = ВторойМассив.Количество());

Если МассивыСовпадают Тогда
Для Сч = 1 По ЭлементовМассива Цикл
Если ПервыйМассив[Сч-1] <> ВторойМассив[Сч-1] Тогда
Возврат Ложь
КонецЕсли;
КонецЦикла;
КонецЕсли;

Возврат МассивыСовпадают

КонецФункции
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 11205
 0 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 12
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
COM-подключение к базе 7.7 из 8.2 1С 5
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Excel файл как Внешний источник данных 6
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.