helpf.pro
Регистрация
 +2 
Распечатать

1С 8.2 УП : Получение расшифровки для текущей ячейки СКД

Код 1C v 8.х
  //   “Результат” – поле табличного документа.

&НаСервере
Функция ПолучитьЗначениеРасшифровки(КодРасшифровки)
Если КодРасшифровки = Неопределено тогда
Возврат Неопределено;
КонецЕсли;

ДР=ПолучитьИзВременногоХранилища(ДанныеРасшифровки);
КоллекцияПолей = ДР.Элементы[КодРасшифровки].ПолучитьПоля();

Если КоллекцияПолей.Количество() = 0 тогда
Возврат Неопределено
Иначе
Возврат КоллекцияПолей[0].Значение ;
КонецЕсли;
КонецФункции

&НаКлиенте
...
РасшифровкаЗначение = ПолучитьЗначениеРасшифровки(Результат.ТекущаяОбласть.Расшифровка);
...
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 5636
 +2 
Распечатать
Возможно, вас также заинтересует
Microsoft SQL Server Native Client Добавление значения в столбец "datetime" привело к переполнению 0
При формировании отчета на СКД получили ошибку: Microsoft SQL Server Native Client 11.0: Добавление значения в столбец "datetime" привело к переполнению Подробнее текст такой: ... по причине: Ошибка компоновки данных по причине: Ошибка...
Вертикальная автофиксация для СКД 0
В СКД очень не хватает возможности автофиксации строк. Обусловлено это невозможностью однозначно определить их количество в общем случае. Однако в большинстве случаев это можно сделать Обращаю ваше внимание, что...
Внешние источники данных 0
Почему данная возможность вызывает такой интерес? Любой человек, который программировал в 1С при этом достаточно неплохо знаком с SQL и хотя бы в общих чертах знаком с архитектурой и принципами разработки других...
Временные таблицы в отчетах СКД 0
Нужно в отчете СКД Связать Данные из Регистра Накопления ВзаиморасчетыСРаботниками и Табличной Части Документа ЗарплатаКВыплате по Ссылке на Документ и ФизЛицу! И вывести полученные данные за указанный Период(с...
Временные таблицы, что из себя представляют и как с ними работать? 5
Временные таблицы - хранятся на сервере и позволяют писать более простые запросы. Временные таблицы хранятся в объекте типа МенеджерВременныхТаблиц . Когда этот объект уничтожается, уничтожаются и временные...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.