helpf.pro
Регистрация
 -2 
Распечатать

1С 8.2 УП : Функция переводит Десятичное число в Шестнадцатеричное и обратно

Код 1C v 8.х
 // Функция переводит десятичное число в шестнадцатеричное
// Параметры: _Число - Число - Десятичное число
// Возвращаемое значение: Строка - Шестнадцатеричное число
//
Функция DecToHex(Знач _Число)
База = 16;
Результат = "";
Пока _Число <> 0 Цикл
Поз =_Число % База;
Результат = Сред("0123456789ABCDEF", Поз + 1, 1) + Результат;
_Число = Цел(_Число / База);
КонецЦикла;
Возврат Результат;
КонецФункции // DecToHex()

// Функция переводит шестнадцатеричное число в десятичное
// Параметры: _Hex - Строка - Шестнадцатеричное число
// Возвращаемое значение: Число - Десятичное число
//
Функция HexToDec(Знач _Hex)
База = 16;
_Hex = СокрЛП(_Hex);
СтаршаяСтепень = СтрДлина(_Hex) - 1;
Результат = 0;
счСимволов = 1;
Пока СтаршаяСтепень >=0 Цикл
_HexСимвол = Сред(_Hex, счСимволов, 1);
Представление = Найти("0123456789ABCDEF", _HexСимвол) - 1;
Результат = Результат + Представление * Степень(База, СтаршаяСтепень);
СтаршаяСтепень = СтаршаяСтепень - 1;
СчСимволов = СчСимволов + 1;
КонецЦикла;
Возврат Результат;
КонецФункции // HexToDec()
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 8726
 -2 
Распечатать
Возможно, вас также заинтересует
Выгрузка картинок из базы 1С в XML 2
В нынешнее время для электронного каталога или интернет-магазина необходимо выгружать не только информацию о цене и характеристиках товара, но и сопутствующие изображения. Хранящиеся в базе или связанные с...
Дерево значений в таблицу значений или в табличную часть и обратно 0
Для одной организации надо было реализовать документы, где вместо табличной части надо использовать дерево и все это на управляемых формах. Но дерево нельзя сохранить в базе в текущем виде. Пришлось использовать...
Как в периодическом независимом регистре сведений удалить все записи по валютам с наименованиями? 0
Как в периодическом независимом регистре сведений «КурсыВалют» удалить все записи по валютам с наименованиями «EUR» и «USD», период которых меньше 01 января 2005 года? Сначала получим таблицу записей, которые необходимо...
Как передать таблицу значений в web-сервис или на тонкого клиента 0
Привыкли 1С-ники работать с таблицами значений. Еще в 1С7.7 можно было здорово оптимизировать работы не применяя запросы, а использую именно таблицы значений. Но все рано или поздно заканчивается. К чему это я, а к тому...
Как преобразовать дату в формат RFC 822 и обратно? 0
Создавая обмены данными между 1С и сайтами, часто приходится форматировать вывод даты в стандарт RCF-822 или преобразовывать его в понятную для 1С ДатуВремя. Дата в формате RFC-822 выглядит так: Tue, 12 Aug 2013 14:15:00 +0400 Небольшая...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.