helpf.pro
Регистрация
 +1 
Распечатать

1С 8.3 : Как сделать фото на мобильном устройстве

Источник mobile-1s.ru

не забываем в свойствах конфигурации установить Требуемые разрешения "Мультимедиа"

Код 1C v 8.3
 

&НаКлиенте
Процедура КомандаСоздатьФото(Команда)

ДанныеФото = ПолучитьДанныеФотоСнимка();

Если ДанныеФото <> Неопределено Тогда
ТекущееФото = ДанныеФото.ПолучитьДвоичныеДанные();
Фото = ПоместитьВоВременноеХранилище(ТекущееФото, Новый УникальныйИдентификатор);
КонецЕсли;

КонецПроцедуры

&НаКлиенте
Функция ПолучитьДанныеФотоСнимка()

Данные = Неопределено;

#Если МобильноеПриложениеКлиент Тогда

Если СредстваМультимедиа.ПоддерживаетсяФотоснимок() Тогда

ТипКамерыДанные = ОбщегоНазначенияСервер.ПолучитьЗначениеКонстанты("ТипКамеры");
Если ТипКамерыДанные = ПредопределенноеЗначение("Перечисление.ТипКамеры.Задняя") Тогда
ТипКамеры = ТипКамерыУстройства.Задняя;
ИначеЕсли ТипКамерыДанные = ПредопределенноеЗначение("Перечисление.ТипКамеры.Передняя") Тогда
ТипКамеры = ТипКамерыУстройства.Передняя;
Иначе
ТипКамеры = ТипКамерыУстройства.Авто;
КонецЕсли;

РазрешениеВысота = ОбщегоНазначенияСервер.ПолучитьЗначениеКонстанты("РазрешениеВысота");
РазрешениеШирина = ОбщегоНазначенияСервер.ПолучитьЗначениеКонстанты("РазрешениеШирина");

//для устройств IOS этот параметр игнорируется
пКачество = ОбщегоНазначенияСервер.ПолучитьЗначениеКонстанты("КачествоФото");
Если пКачество = 0 Тогда
пКачество = 1;
КонецЕсли;

Если РазрешениеВысота <> 0 И РазрешениеШирина <> 0 Тогда
РазрешениеКамеры = Новый РазрешениеКамерыУстройства;
РазрешениеКамеры.Высота = РазрешениеВысота;
РазрешениеКамеры.Ширина = РазрешениеШирина;
Данные = СредстваМультимедиа.СделатьФотоснимок(ТипКамеры, РазрешениеКамеры, пКачество);

Иначе
Данные = СредстваМультимедиа.СделатьФотоснимок(ТипКамеры, , пКачество);
КонецЕсли;

Возврат Данные;
Иначе
Сообщить("Данное устройство не поддерживает фотоснимок!")
КонецЕсли;

#КонецЕсли

Возврат Данные;

КонецФункции
Разместил:   Версии: | 8.3 |  Дата:   Прочитано: 1566
 +1 
Распечатать
Возможно, вас также заинтересует
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
rphost занимает память и грузит процессор 12
У многих возникают проблемы с rphost.exe, разного вида: rphost занимает всю память rphost грузит процессор rphost жрет память причем 1С даже на запущена, а в диспетчере следующее: ежеминутно расчет на 2-3 мегабайта. Как быть и...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.