helpf.pro
Регистрация
 0 
Распечатать

1С 8.3 : Как вызвать альтернативный вариант сканирования штрихкода

Источник mobile-1s.ru

скачиваем с Google play Barcode scanner

Код 1C v 8.3
 
&НаКлиенте
Процедура ЗапуститьСканированиеBarcode()

#Если МобильноеПриложениеКлиент Тогда

НовВз = Новый ЗапускПриложенияМобильногоУстройства();
НовВз.Действие="com.google.zxing.client.android.SCAN";

Для Каждого Стр Из НовВз.ДополнительныеДанные Цикл

Если сокрЛП(Стр.Ключ) = "SCAN_RESULT" Тогда
Штрихкод = Стр.Значение;
//Сообщить(Стр.Ключ+" - "+Стр.Значение);

Структура = ОбщегоНазначенияСервер.ПолучитьОбъектПоШтрихКоду(ШтрихКод);
Если Структура = Неопределено Тогда
пТовар = Неопределено;
Иначе
пТовар = Структура.Номенклатура;

ОткрытьЗначение(пТовар);

КонецЕсли;
КонецЕсли;
КонецЦикла;

#КонецЕсли

КонецПроцедуры
Разместил:   Версии: | 8.3 |  Дата:   Прочитано: 1500
 0 
Распечатать
Возможно, вас также заинтересует
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Как в 1С проложить маршрут используя GoogleMaps API V3 3
Клиенты частенько просят настроить отображение маршрутов перемещения по разным адресам в 1С, например для курьеров и т.д. В примере описан способ отражения карт GoogleMaps в 1С: Для Каждого Стр Из НаВходе Цикл нСтр =...
Как мы писали парсер сайта с ценами для 1С 1
Недавно, мой постоянный клиент решил проводить маркетинговые исследования по изменению цен на товары у конкурентов... и эти данные захотел использовать в 1С в связке с его прайс-листом + куча отчетов с графиками и...
Чтение данных с сайта в формате XML и загрузка в 1С 1
При разработке веб проекта нам потребовалось получать с одного сайта данные в формате XML и загружать их в 1С. Сайт выдает XML вида (Ссылка на этот xml в коде, внизу): This XML file does not appear to have any style information associated with it
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.