helpf.pro
Регистрация
 0 
Распечатать

Получение списка принтеров и Подключение сетевого принтера

Для работы с сетевыми ресурсами в WSH предназначен объект WshNetwork. Из "1С:Предприятие" можно напрямую управлять сетевыми ресурсами, в том числе и принтерами.

Получить список принтеров
Код 1C v 8.х
 Функция ПолучитьСписокПринтеров()
СписокПринтеров = Новый СписокЗначений;
СписокПринтеров.Очистить();
Принтеры = Новый COMОбъект(«WScript.Network»);
Prn = Принтеры.EnumPrinterConnections();
й = 0;
Пока й < Prn.Count() – 1 Цикл
СписокПринтеров.Добавить(Prn.Item(й + 1));
й = й + 2;
КонецЦикла;
Принтер = СписокПринтеров.ВыбратьЭлемент();
//даём пользователю выбрать принтер
Если Принтер <> Неопределено Тогда
……
Сообщить(Принтер.Значение); // например
……
КонецЕсли;
КонецФункции


Подключение сетевого принтера
Код 1C v 8.х
 //Создаём новый СОМ-объект
Сеть = Новый СОМОбъект("Wscript.Network");
Попытка
//устанавливаем принтер
Сеть.AddWindowsPrinterConnection("\\ИмяСервера\ИмяПринтера");
//делаем этот принтер принтером по умолчанию
Сеть.SetDefaultPrinter("\\ИмяСервера\ИмяПринтера");
Исключение
//в случае неудачного подключения принтера
Сообщить("Невозможно произвести подключение");
КонецПопытки;

Объект WshNetwork позволяет определить список подключенных сетевых принтеров. Для этого используется метод EnumPrinterConnections, который возвращает коллекцию принтеров. Данную коллекцию можно перебрать с помощью конструкции
Код 1C v 8.х
 Для каждого... из... Цикл...КонецЦикла   
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 11954
 0 
Распечатать
Возможно, вас также заинтересует
Конструктор схемы компоновки данных - Закладка Ресурсы 0
На данной закладке можно определить поля -ресурсами, а также определяются агрегатные функции используемые при вычислении данных полей по группировкам. https://helpf.pro/uploads/img/sukpd040.png «Доступные поля» - список доступных...
Получить имя принтера выбранного по умолчанию 0
// maharbA Функция Hex(Пар) Результат=" " ; Пока Пар 0 Цикл Результат=Сред(" 0123456789ABCDEF" ,Пар+1,1)+Результат; Пар=Цел(Пар/16) ; КонецЦикла; Возврат " " +Результат; КонецФункции Функция ПолучитьПринтерПоУмолчанию() ...
Сводные таблицы 0
Значения измерений отображаются в шапке или боковике, а ячейки области данных содержат сводную информацию на пересечении данных измерений. Пользователь имеет возможность методом перетаскивания (drag-n-D_rop) добавить или...
Создание сводной таблицы 0
В специальном окне «Поля сводной таблицы», которое отображается при активизации сводной таблицы, можно включать и выключать измерения и ресурсы. Если оно не отображается, то щелкните правой кнопкой на ячейке сводной...
Посмотреть все результаты поиска похожих
Комментарии
snfr1c
10.11.2011 16:41Комментарий: 1
snfr1c
Код 1C v 8.2 УП
 Сервис = ПолучитьCOMОбъект("winmgmts:{impersonationLevel=impersonate}!\\" +ИмяКомпьютера() + "\root\cimv2");
ПринтерыВсе = Сервис.ExecQuery("Sel ect * from Win32_Printer");
Для Каждого Принтер из ПринтерыВсе Цикл
Сообщить(Принтер.Name);
КонецЦикла;
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.