helpf.pro
Регистрация
 0 
Распечатать

Обработчик события для COM объекта

Добрый день.

Есть задача:
в элемент управления "Поле HTML документа" загружается некая web форма, на которой есть некий InputElement. Необходимо реализовать обработчик события onchange этого элемента.
Пытаюсь сделать так:
Код 1C v 8.х
 Процедура outMsgChange()
//какой-то код

КонецПроцедуры

Процедура FWДокументСформирован(Элемент)
FWDoc = ЭтаФорма.ЭлементыФормы.FW.Документ;
Если FWDoc.URLUnencoded= "file:///E:/index.html" Тогда

inMsg = FWDoc.all.inMessage;
outMsg = FWDoc.all.outMessage;
outMsg.onchange = outMsgChange;
КонецЕсли;
КонецПроцедуры


При проверке модуля возникает ошибка:
Переменная не определена (outMsgChange)
Толстый клиент (обычное приложение)

Есть какие-то варианты назначить для web контрола в качестве обработчика процедуру модуля?
Что-то аналогичное коду на C#:

this.FormClosed += new FormClosedEventHandler(Form1_FormClosed);

Спасибо.
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 5310
 0 
Распечатать
Возможно, вас также заинтересует
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Быстрый отбор в справочнике по первой букве 0
В статье описан способ быстрой организации отбора в списке справочника по первой букве наименования. Механизм легко дотачивается под собственные нужды. https://helpf.pro/uploads/img/_1-T4ZDj6uNPX.png // ПРОЦЕДУРЫ И ФУНКЦИИ МОДУЛЯ ...
Ввод документа на основании - Программно 5
НовДок = Документы.ПеречислениеНДФЛвБюджет.СоздатьДокумент(); //Заполнить - вызывает ОбработкаЗаполнения(Основание) в документе ПеречислениеНДФЛвБюджет ...
Ввод записей в журнал расчетов 0
Добавление записи в журнал расчетов: Метод Новая может быть вызван где угодно, в глобальном модуле, модуле обработок, документов и т.д. Данный метод проверяет корректность заполненных реквизитов журнала расчетов....
Посмотреть все результаты поиска похожих
Комментарии
DJ_Serega
03.04.2013 20:09Комментарий: 3
DJ_Serega
Ну функция в 1С и возвращает значение. Как по мне, ощущение правильное )
barabas54
03.04.2013 12:18Комментарий: 2
barabas54
пробовал и так - не работает
при выполнении кода:

{Справочник.Справочник1.Форма.ФормаЭлемента.Форма(24)}: Ошибка при установке значения атрибута контекста (onchange)
outMsg.onchange = outMsgChange();
по причине:
Произошла исключительная ситуация (htmlfile): Не поддерживается

такое ощущение, что для outMsg.onchange присваивается значение, которое возвращает функция, а не ссылка на саму функцию
E_Migachev
03.04.2013 10:14Комментарий: 1
E_Migachev
outMsg.onchange = outMsgChange; - ты обращаешься к перемнной
outMsg.onchange = outMsgChange(); а вот так к функции т.е. процедуру переделай в функцию
Код 1C v 8.х
  Функция outMsgChange()
//какой-то код
Возврат КакоетоЗначение;
КонецФункции
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.