helpf.pro
Регистрация
 +4 
Распечатать

Как программно прочитать Журнал Регистрации?

Код 1C v 8.х
  ИмяФайла=ПолучитьИмяВременногоФайла("XML");
Результат.Очистить();
Фильтр=Новый Структура;
Фильтр.Вставить("ДатаНачала", НачалоПериода);
Фильтр.Вставить("ДатаОкончания", ОкончаниеПериода);
Фильтр.Вставить("Событие", "_$Data$_.Post");
Состояние("Выгрузка журнала...");
ВыгрузитьЖурналРегистрации(ИмяФайла, Фильтр, "Дата, Метаданные, Данные, ПредставлениеДанных, ИмяПользователя");
Состояние("Обработка журнала...");
ЧтениеXML=Новый ЧтениеXML;
ЧтениеXML.ОткрытьФайл(ИмяФайла);
ПостроительDOM=Новый ПостроительDOM;
ДокументDOM=ПостроительDOM.Прочитать(ЧтениеXML);
Event=ДокументDOM.ПолучитьЭлементыПоИмени("v8e:Event");
Для й=0 По Event.Количество()-1 Цикл
ДочерниеУзлы=Event[й].ДочерниеУзлы;
Для Каждого Узел Из ДочерниеУзлы Цикл
Если Узел.ИмяУзла="v8e:Date" Тогда
ДатаСобытия=СтрЗаменить(Узел.ТекстовоеСодержимое, "T", "");
ДатаСобытия=СтрЗаменить(ДатаСобытия, ":", "");
ДатаСобытия=Дата(СтрЗаменить(ДатаСобытия, "-", ""));
ИначеЕсли Узел.ИмяУзла="v8e:MetadataName" Тогда
МетаданныеДокумента=СтрЗаменить(Узел.ТекстовоеСодержимое, "Document.", "");
ИначеЕсли Узел.ИмяУзла="v8e:Data" Тогда
УИД=Узел.ТекстовоеСодержимое;
ИначеЕсли Узел.ИмяУзла="v8e:DataPresentation" Тогда
ПредставлениеДанных=Узел.ТекстовоеСодержимое;
ИначеЕсли Узел.ИмяУзла="v8e:UserName" Тогда
Пользователь=Узел.ТекстовоеСодержимое;
КонецЕсли;
КонецЦикла;
Ссылка=Документы[МетаданныеДокумента].ПолучитьСсылку(Новый УникальныйИдентификатор(УИД));
ДатаОбъекта=Ссылка.Дата;

НоваяСтрока=Результат.Добавить();
НоваяСтрока.ДатаСобытия=ДатаСобытия;
НоваяСтрока.ДатаОбъекта=ДатаОбъекта;
НоваяСтрока.ПредставлениеДанных=ПредставлениеДанных;
НоваяСтрока.Пользователь=Пользователь;
НоваяСтрока.РазностьДат=Окр((ДатаСобытия-ДатаОбъекта)/86400);
НоваяСтрока.Ссылка=Ссылка;
КонецЦикла;
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 9512
 +4 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
Microsift Visual C++ Runtime Library Program ...1cv77s.exe abnormal program termination 0
При запуске 1С 7.7 выдает сообщение: Microsift Visual C++ Runtime Library Program C:Program Files1Cv77BIN1cv77s.exe abnormal program termination Вариант 1. Обычно это происходит, когда повреждается файл регистрации. Точнее, когда не дописывает
Ввод договоров ГПХ в ЗУП (счет 76) 5
Часто меня спрашивают: Как правильно отразить договор ГПХ в ЗУП? Ниже небольшая, последовательная инструкция: Прием на работу Сведения о физическом лице, выполняющем работы по договору подряда, должны быть внесены...
Ввод документа на основании - Программно 5
НовДок = Документы.ПеречислениеНДФЛвБюджет.СоздатьДокумент(); //Заполнить - вызывает ОбработкаЗаполнения(Основание) в документе ПеречислениеНДФЛвБюджет ...
Ввод записей в журнал расчетов 0
Добавление записи в журнал расчетов: Метод Новая может быть вызван где угодно, в глобальном модуле, модуле обработок, документов и т.д. Данный метод проверяет корректность заполненных реквизитов журнала расчетов....
Посмотреть все результаты поиска похожих
Комментарии
swr812
18.11.2013 21:37Комментарий: 1
swr812
Код 1C v 8.2 УП
 ИначеЕсли Узел.ИмяУзла="v8e:Metadata" Тогда
МетаданныеДокумента=СтрЗаменить(Узел.ТекстовоеСодержимое, "Document.", "");
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.