helpf.pro
Регистрация
 +1 
Распечатать

Функция копирования файла с выводом сообщений о результатах

Код 1C v 8.х
 //Возвращает Истина - скопирован, иначе Ложь 
Функция СкопироватьФайл(ИмяФайлаИсточник, ИмяФайлаНазначение, ВыдаватьСообщения = Ложь) Экспорт
Попытка
ПозицияСимвола = СтрДлина(ИмяФайлаНазначение);
Пока ПозицияСимвола >= 1 Цикл
Если Сред(ИмяФайлаНазначение, ПозицияСимвола, 1) = "\" Тогда
Возврат ПозицияСимвола;
КонецЕсли;
ПозицияСимвола = ПозицияСимвола - 1;
КонецЦикла;
КаталогФайла=Сред(ИмяФайлаНазначение, 1, ПозицияСимвола - 1);
СоздатьКаталог(КаталогФайла);
КопироватьФайл(ИмяФайлаИсточник, ИмяФайлаНазначение);
Исключение
Сообщение = "Ошибка при копировании: " + ОписаниеОшибки() +
" (источник: " + ИмяФайлаИсточник + "; приемник: " + ИмяФайлаНазначение + ")";
Если ВыдаватьСообщения Тогда
Сообщить(Сообщение);
КонецЕсли;
Предупреждение(Сообщение);
Возврат Ложь;
КонецПопытки;
Возврат Истина;
КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6663
 +1 
Распечатать
Возможно, вас также заинтересует
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
ZIP-архив Разделить и Объединить Файл 0
При работе с большими объемами данных могут возникнуть проблемы при пересылке архивных файлов. Типичной такой ситуацией является ограничение некоторых почтовых серверов на размер сообщения - если письмо превышает...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Восстановление узла распределенной информационной базы из резервной копии 0
В случае возникновения ситуации, при которой необходимо восстановить резервную копию информационной базы, работающую в рамках распределенной информационной базы, можно воспользоваться следующими рекомендациями. ...
Вывод информации о программе, Пользователе, Интерфейсе, Правах и т.д 0
//Вывод в окно сообщений ОчиститьОкноСообщений(); //Очистим окно сообщений Состояние(" Вывожу информацию!" ); Сообщить(" ИНФОРМАЦИЯ О ПРОГРАММЕ И ПОЛЬЗОВАТЕЛЕ!" ," I" ); Сообщить(" Имя Компьтера - " + ИмяКомпьютера()); ...
Посмотреть все результаты поиска похожих
Комментарии
bewazay
20.01.2016 16:51Комментарий: 1
bewazay

Возврат ПозицияСимвола; Наверное надо заменить на Прервать;

Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.