helpf.pro
Регистрация
 0 
Распечатать

Реквизит ~ Проверка на заполненность реквизитов формы, с признаком АвтоОтметкаНезаполненного

Код 1C v 8.х
  //Проверка на заполненность реквизитов формы, для которых установлен признак АвтоОтметкаНезаполненного
Функция ПроверкаАвтоОтметкаНезаполненного(ЭлементыФормы) Экспорт

Результат = Ложь;

Для каждого Элемент Из ЭлементыФормы Цикл
Если ТипЗнч(Элемент) = Тип("ПолеВвода") Тогда
Если Элемент.АвтоОтметкаНезаполненного И ЗначениеНеЗаполнено(Элемент.Значение) Тогда
Сообщить("Необходимо заполнить обязательное поле ввода: " + Элемент.Подсказка, СтатусСообщения.Внимание);
Результат = Истина;
КонецЕсли;

ИначеЕсли ТипЗнч(Элемент) = Тип("ТабличноеПоле") Тогда

СоставПоля = Элемент.Значение;
Колонки = Элемент.Колонки;
Попытка // для ДокументСписок вызовет исключение

Для каждого Строка Из СоставПоля Цикл
Для каждого Колонка Из Колонки Цикл
Если ТипЗнч(Колонка.ЭлементУправления) = Тип("ПолеВвода") Тогда
Если Колонка.АвтоОтметкаНезаполненного И ЗначениеНеЗаполнено(Строка[Колонка.Данные]) Тогда
Сообщить("Необходимо заполнить обязательное поле ввода табличной части: " + Колонка.ТекстШапки, СтатусСообщения.Внимание);
Результат = Истина;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЦикла;
Исключение
КонецПопытки;

КонецЕсли;

КонецЦикла;

Возврат Результат;
КонецФункции
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 11453
 0 
Распечатать
Возможно, вас также заинтересует
Как получить список зарегистрированных пользователей базы 1С 2
Выборка = ПользователиИнформационнойБазы.ПолучитьПользователей(); Для Каждого ЭлементМассива Из Выборка Цикл ИмяПользователя = ЭлементМассива.Имя; ПолноеИмяПользователя = ЭлементМассива.ПолноеИмя; ЕстьПароль...
Обработка Универсальный обмен данными в формате XML 6
Обработка Универсальный обмен данными в формате XML (обработка универсальныйобменданнымиxml) Обработка " Универсальный обмен данными в формате XML" предназначена для загрузки и выгрузки данных в файл из любой...
Реквизит ~ Функция проверяет, все ли реквизиты элемента заполнены(Краткий вариант проверки)? 0
// Возвращаемое значение: // Ложь ,если не все реквизиты заполнены // Истина, если все отмеченные реквизиты заполнены Функция ПроверитьНезаполненныеРеквизиты(Элементы) Экспорт Для каждого стр Из Элементы Цикл Если...
Формат конфигурационного файла программы запуска 1CEStart 3
Формат конфигурационного файла программы запуска Файл расположен в каталоге %APPDATA%1C1CEStart В конфигурационном файле содержится следующая информация: - Версия платформы, которую нужно использовать по умолчанию; -...
Посмотреть все результаты поиска похожих
Комментарии
servs
02.09.2010 12:32Комментарий: 1
servs
Спасибо, лень было писать самому) сейчас протестирую)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.