helpf.pro
Регистрация
 0 
Распечатать

Как удалить все элементы справочника?

Для удаления всех элементов справочника можно использовать объект СправочникВыборка.<имя>, с помощью которого осуществлять обход и удаление всех элементов справочника. При этом следует учитывать, что если справочник иерархический, то выборка должна быть также иерархической, так как при удалении элемента удаляются и все его подчиненные элементы. Например:
Код 1C v 8.х
 
Выборка = Справочники.Номенклатура.ВыбратьИерархически();
Пока Выборка.Следующий() Цикл
Выборка.Удалить();
КонецЦикла;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 11955
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
ZIP-архив Чтение 0
Для того чтобы прочитать файлы из ZIP-архива необходимо выполнить несколько простых действий: - Открыть необходимый архив - Распаковать файлы Создание объекта ЧтениеZIPФайла можно осуществить двумя путями - создать...
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 21
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Был ли изменен элемент справочника? 0
// Модифицированность() - Определяет, был ли изменен объект после считывания из базы данных. // НО Метод не позволяет определить, был ли изменен объект другими пользователями. Если Модифицированность() тогда ...
Посмотреть все результаты поиска похожих
Комментарии
DanyaD
01.02.2013 11:04Комментарий: 2
DanyaD
Выборка = Справочники.Дела.Выбрать();
Пока Выборка.Следующий()Цикл
ТекЭлемент = Выборка.ПолучитьОбъект();
Попытка
ТекЭлемент.Удалить();
Исключение Сообщить("Не удалось удалить элемент!" + ТекЭлемент.Код);
КонецПопытки;
КонецЦикла;
kvr
01.12.2011 18:08Комментарий: 1
kvr
Код 1C v 8.х
    
Код 1C v 8.2 УП
    
Не уверен, что так будет работать. При удалении выборка может сбиться.

Лучше так:

Код 1C v 8.х
 
Пока 1=1 Цикл
Выборка = Справочники.ИзмененияКонфигурации.ВыбратьИерархически();
Если Выборка.Следующий() Тогда
ТекЭлемент = Выборка.ПолучитьОбъект();
ТекЭлемент.Удалить();
Иначе
прервать;
КонецЕсли;
КонецЦикла;

Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.