helpf.pro
Регистрация
 +1 
Распечатать

Табличное поле ~ Оформление строк, ячеек табличного поля (цвет, текст)

Одним из полезных свойств элемента управления Табличное поле является возможность настройки оформления его строк программным способом.
Для иллюстрации этой возможности мы снова воспользуемся формой справочника Номенклатура и придадим ей «нестандартный» вид.
Откроем в конфигураторе форму списка справочника Номенклатура и создадим обработчик события формы ПриОткрытии со следующим текстом:
Код 1C v 8.х
 Процедура ПриОткрытии()

СписокСправочника = ЭлементыФормы.СправочникСписок;

// Задать режим чередования цветов строк
СписокСправочника.ЦветФонаЧередованияСтрок = WEBЦвета.Бежевый;
СписокСправочника.ЧередованиеЦветовСтрок = Истина;

// Скрыть линии сетки
СписокСправочника.ВертикальныеЛинии = Ложь;
СписокСправочника.ГоризонтальныеЛинии = Ложь;

КонецПроцедуры

Вначале мы задаем режим чередования цветов фона строк списка. Первая строка будет выводиться на бежевом фоне, вторая на белом, третья снова на бежевом и т. д.
Затем мы скрываем линии, разделяющие колонки и строки.
Теперь откроем обработчик события ПриВыводеСтроки табличного поля списка справочника и добавим в него следующие строки:
Код 1C v 8.х
 Процедура СправочникСписокПриВыводеСтроки(Элемент, ОформлениеСтроки,ДанныеСтроки)

// Для элементов отобразить цену и...
Если Не ДанныеСтроки.ЭтоГруппа Тогда
ОтборНоменклатуры = Новый Структура;
ОтборНоменклатуры.Вставить("Номенклатура", ДанныеСтроки.Ссылка);
ОформлениеСтроки.Ячейки.Цена.ОтображатьТекст = Истина;
АктуальнаяЦена = РегистрыСведений.Цены.ПолучитьПоследнее( , ОтборНоменклатуры).Цена;
ОформлениеСтроки.Ячейки.Цена.Текст = АктуальнаяЦена;

// низкие цены выделим другим цветом
Если АктуальнаяЦена<500 Тогда
ОформлениеСтроки.Ячейки.Цена.ЦветТекста = WEBЦвета.Васильковый;
КонецЕсли;

// Раздвинуть строку, если длинное наименование
Если СтрДлина(СокрЛП(ДанныеСтроки.Наименование))>30 Тогда
ОформлениеСтроки.Ячейки.Наименование.АвтоВысотаЯчейки = Истина;
ОформлениеСтроки.Ячейки.Наименование.ВысотаЯчейки = 3;
КонецЕсли;

// Пример Оформления ВСЕЙ СТРОКИ
// ОформлениеСтроки.Шрифт = Новый Шрифт(ОформлениеСтроки.Шрифт , , , Истина, Ложь);
// ОформлениеСтроки.ЦветФона = Новый Цвет(255, 245, 207);
КонецЕсли;
КонецПроцедуры

Здесь в случае вывода элемента справочника мы анализируем длину его наименования. Если оно более 30 символов, устанавливаем автоматическое определение высоты ячейки, ограничивая ее максимальную высоту тремя строками.
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 32519
 +1 
Распечатать
Возможно, вас также заинтересует
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 21
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Был ли изменен элемент справочника? 0
// Модифицированность() - Определяет, был ли изменен объект после считывания из базы данных. // НО Метод не позволяет определить, был ли изменен объект другими пользователями. Если Модифицированность() тогда ...
Быстрый отбор в справочнике по первой букве 0
В статье описан способ быстрой организации отбора в списке справочника по первой букве наименования. Механизм легко дотачивается под собственные нужды. https://helpf.pro/uploads/img/_1-T4ZDj6uNPX.png // ПРОЦЕДУРЫ И ФУНКЦИИ МОДУЛЯ ...
Посмотреть все результаты поиска похожих
Комментарии
Gorus
14.12.2011 18:37Комментарий: 3
Gorus
Условное оформление для формы можно задать визуально прямо в редакторе: в свойствах формы есть пункт "Условное оформление" - жмем "Открыть" и открывается список с правилами оформления. В нем додаем новую строку, в которой указываем оформление, условие срабатывания и поле, которое будет оформляться. Для большинства случаев этого вполне достаточно. Если не достаточно - то же самое можно сделать и программно:
Код 1C v 8.2 УП
 ЭлементУсловногоОформления = УсловноеОформление.Элементы.Добавить();
ОформляемоеПоле = ЭлементУсловногоОформления.Поля.Элементы.Добавить();
ОформляемоеПоле.Поле = Новый ПолеКомпоновкиДанных("ПланНоменклатура");
ЭлементОтбора = ЭлементУсловногоОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("План.Разница");
ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
ЭлементОтбора.ПравоеЗначение = 100;
ЭлементУсловногоОформления.Оформление.УстановитьЗначениеПараметра("ЦветФона", WebЦвета.СеребристоСерый);

Пример кода взят отсюда.
E_Migachev
07.12.2011 17:38Комментарий: 2
E_Migachev
Gorus, спасибо, убрал! Если у вас есть пример как сделать в УП выложите пожалуйста *13
Gorus
07.12.2011 13:38Комментарий: 1
Gorus
В УП нужно делать через УсловноеОформление. Нужно снять тег УП.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.