helpf.pro
Регистрация
 0 
Распечатать

Массив ~ Как Свернуть Массив?

Код 1C v 8.х
 
НовыйМассив = Новый Массив; Соответствие = Новый Соответствие;
Для каждого ЭлементМассива Из Массив Цикл
Соответствие.Вставить(ЭлементМассива);
КонецЦикла;
Для каждого КлючИЗначение Из Соответствие Цикл
НовыйМассив.Добавить(КлючИЗначение.Значение);
КонецЦикла;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 12062
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Google maps, поиск оптимального маршрута 2
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; *...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Посмотреть все результаты поиска похожих
Комментарии
denium
26.02.2012 18:19Комментарий: 3
denium
В данном примере ошибка, нужно заменить
НовыйМассив = Новый Массив; Соответствие = Новый Соответствие;
Для каждого ЭлементМассива Из Массив Цикл
Соответствие.Вставить(ЭлементМассива);
КонецЦикла;
Для каждого КлючИЗначение Из Соответствие Цикл
НовыйМассив.Добавить(КлючИЗначение.Ключ);
КонецЦикла;
Bulat
23.12.2011 16:57Комментарий: 2
Bulat
... и спасибо за код.
Bulat
23.12.2011 16:53Комментарий: 1
Bulat
Возможно в каких-то версиях значение заполнялось по умолчанию по ключу, но 8.2 необходимо написать
Соответствие.Вставить(ЭлементМассива, ЭлементМассива);
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.