helpf.pro
Регистрация
 0 
Распечатать

Функция создает КОПИЮ переданного Массива, Структуры или Соответствия

Код 1C v 8.х
 
// Создает копию переданного массива, структуры или соответствия
//
// Параметры:
// КоллекцияИсходная: тип Массив, Структура, Соответствие - исходная коллекция
// Возвращаемое значение:
// КоллекцияКопия: тип Массив, Структура, Соответствие - копия исходной коллекции
//
Функция СкопироватьУниверсальнуюКоллекцию(КоллекцияИсходная) Экспорт

Если ТипЗнч(КоллекцияИсходная)=Тип("Массив") Тогда

КоллекцияКопия=Новый Массив;

Для Каждого Элемент Из КоллекцияИсходная Цикл

КоллекцияКопия.Добавить(Элемент);

КонецЦикла;

Возврат КоллекцияКопия;

ИначеЕсли ТипЗнч(КоллекцияИсходная)=Тип("Структура") Тогда

КоллекцияКопия=Новый Структура;

Для Каждого Элемент Из КоллекцияИсходная Цикл

КоллекцияКопия.Вставить(Элемент.Ключ,Элемент.Значение);

КонецЦикла;

Возврат КоллекцияКопия;

ИначеЕсли ТипЗнч(КоллекцияИсходная)=Тип("Соответствие") Тогда

КоллекцияКопия=Новый Соответствие;

Для Каждого Элемент Из КоллекцияИсходная Цикл

КоллекцияКопия.Вставить(Элемент.Ключ,Элемент.Значение);

КонецЦикла;

Возврат КоллекцияКопия;

Иначе

Сообщить("Неверный тип универсальной коллекции для копирования");
Возврат Неопределено

КонецЕсли;

КонецФункции
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 7400
 0 
Распечатать
Возможно, вас также заинтересует
Внешние обработки, печатные формы, обработки по заполнению табличных частей 2
Справочник «Внешние обработки, печатные формы, обработки по заполнению табличных частей» содержит список произвольных обработок, произвольных отчетов, дополнительных печатных форм, обработок для заполнения ТЧ...
Внешняя печатная форма, дополнительные параметры для печати 0
Внешняя обработка (Печатная форма), содержащая: Необязательный реквизит « ДополнительныеПараметры » произвольного типа , которому будут передаваться дополнительные параметры примитивного типа в виде структуры. ...
Выборка (перебор) бизнес-процессов 0
Выбрать( , , , ) отбора отбора (необязательный) - Структура. Задает реквизит вида расчета и значение этого реквизита, по которому будет создана выборка. Ключ структуры задает имя реквизита, а значение структуры -...
Выборка (перебор) видов расчета 0
Выбрать( , ) (необязательный) - Структура. Задает реквизит вида расчета и значение этого реквизита, по которому будет создана выборка. Ключ структуры задает имя реквизита, а значение структуры - значение отбора по этому...
Выборка запросом, перебор задач 0
Выбрать( Отбор , Порядок ) Отбор (необязательный) - Структура. Задает реквизит вида расчета и значение этого реквизита, по которому будет создана выборка. Ключ структуры задает имя реквизита, а значение структуры -...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.