helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Ввести строку, ввод текста

Код 1C v 8.х
 
Текст = "";
Подсказка = "Введите текст напоминания";
Если ВвестиСтроку(Текст,Подсказка, 0, истина) Тогда
// запомнить текст напоминания
КонецЕсли;


Код 1C v 7.x
 
НК = "";
Если ВвестиСтроку(НК, "Введите код продукции", 40, 1, 9) = 1 Тогда
Koд = HK;
Иначе
Код = "";
КонецЕсли;
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 10201
 0 
Распечатать
Возможно, вас также заинтересует
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Алгоритм шифрования RC4 0
Для решения некоторых задач, иногда требуется имееть возможность шифровать и дешифровывать, какие-то данные. Но при этом нет возможности использовать стороние внешнии компоненты. Предлагаем пример реализации...
Альтернативный перенос остатков между 7.7 и 8.1 (обработкой с ИТС ЗагрузкаДанныхИзТаблДокум) 0
Нашел альтернативный, практически моментальный способ переноса остатков между семерой и восьмерой (так и между восмерками). Не требуется никаких дополнительных усилий, программирования, писания обработок и т.д. и т.п....
В 1С не вводится новый элемент в справочник 0
Новый элемент или группу в справочник нельзя добавить если выключен режим иерархического списка. Для того, чтобы включить этот режим выберите в меню " Действия" пункт " Иерархический список" и установите этот режим.
Ввести дату, ввод даты 1
ДатаНапоминания = РабочаяДата; Подсказка = "Введите дату и время"; ЧастьДаты = ЧастиДаты.ДатаВремя; Если ВвестиДату(ДатаНапоминания, Подсказка, ЧастьДаты) Тогда // обработка даты напоминания КонецЕсли Если...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.