helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Функция преобразует переданную сумму, число в строку вида

ПарСумма - сумма, число

Код 1C v 8.х
 
Функция глРубКоп(ПарСумма) Экспорт
Если Число(ПарСумма)=0 Тогда
Возврат "руб. коп."
КонецЕсли;
Возврат ""+Цел(ПарСумма)+" руб. "+Формат((ПарСумма-Цел(ПарСумма))* 100,"ЧЦ=2; ЧВН=")+" коп."
КонецФункции

//Пример обращения
Процедура КнопкаВыполнитьНажатие(Кнопка)
Сообщить(глРубКоп(ИтогоСумм)); //К примеру ИтогоСумм=875.05; - Результат 875 руб. 05 коп.
КонецПроцедуры



Код 1C v 7.x
 
Функция глРубКоп(ПарСумма) Экспорт
Если Число(ПарСумма)=0 Тогда
Возврат "руб. коп."
КонецЕсли;
Возврат ""+Цел(ПарСумма)+" руб. "+Формат((ПарСумма-Цел(ПарСумма))* 100,"Ч(0)2")+" коп."
КонецФункции

//Пример обращения
ИтогоСумм=875.05;
Сообщить(глРубКоп(ИтогоСумм)); // 875 руб. 05 коп.
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 7279
 0 
Распечатать
Возможно, вас также заинтересует
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Алгоритм шифрования RC4 0
Для решения некоторых задач, иногда требуется имееть возможность шифровать и дешифровывать, какие-то данные. Но при этом нет возможности использовать стороние внешнии компоненты. Предлагаем пример реализации...
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 21
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.