helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Функция преобразует переданную сумму, число в строку вида

ПарСумма - сумма, число

Код 1C v 8.х
 
Функция глРубКоп(ПарСумма) Экспорт
Если Число(ПарСумма)=0 Тогда
Возврат "руб. коп."
КонецЕсли;
Возврат ""+Цел(ПарСумма)+" руб. "+Формат((ПарСумма-Цел(ПарСумма))* 100,"ЧЦ=2; ЧВН=")+" коп."
КонецФункции

//Пример обращения
Процедура КнопкаВыполнитьНажатие(Кнопка)
Сообщить(глРубКоп(ИтогоСумм)); //К примеру ИтогоСумм=875.05; - Результат 875 руб. 05 коп.
КонецПроцедуры



Код 1C v 7.x
 
Функция глРубКоп(ПарСумма) Экспорт
Если Число(ПарСумма)=0 Тогда
Возврат "руб. коп."
КонецЕсли;
Возврат ""+Цел(ПарСумма)+" руб. "+Формат((ПарСумма-Цел(ПарСумма))* 100,"Ч(0)2")+" коп."
КонецФункции

//Пример обращения
ИтогоСумм=875.05;
Сообщить(глРубКоп(ИтогоСумм)); // 875 руб. 05 коп.
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 11645
 0 
Распечатать
Возможно, вас также заинтересует
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 6
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р, НомСтроки, НомЯче
COM-подключение к базе 7.7 из .NET, .NET Core 0
Инсталяция: dotnet add package sabatex.V1C77 или добавить через NUGET пакет sabatex.V1C77. Добавить пространство имен: using sabatex.V1C77; пример использованя: ---C# static void Main(string args) { // создаем строку соединен
Cклонения по падежам 6
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) Результат = " " ;
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура РасчетШириныКолонок(Табличный
Алгоритм шифрования RC4 1
Для решения некоторых задач, иногда требуется имееть возможность шифровать и дешифровывать, какие-то данные. Но при этом нет возможности использовать стороние внешнии компоненты. Предлагаем пример реализации алгоритма шифрования RC4 на встроенном яз
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.