helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Как получить данные о зарегистрированных пользователях информационной базы?

Получение данных о пользователях
Код 1C v 8.х
 Выборка = ПользователиИнформационнойБазы.ПолучитьПользователей();

Для Каждого ЭлементМассива Из Выборка Цикл
ИмяПользователя = ЭлементМассива.Имя;
ПолноеИмяПользователя = ЭлементМассива.ПолноеИмя;
ЕстьПароль = ЭлементМассива.ПарольУстановлен;
Роли = ЭлементМассива.Роли;

Для Каждого Роль Из Роли Цикл
ИмяРоли = Роль.Имя;

КонецЦикла;
КонецЦикла;

В указанной процедуре работа по получению списка пользователей начинается с обращения к свойству глобального контекста ПользователиИнформационнойБазы. Метод ПолучитьПользователей() возвращает массив объектов ПользовательИнформационнойБазы, который обходится потом в цикле.



Для 1С 7.7 посмотрите Пример получения списка пользователей из файла users.usr
Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 8557
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
v7plus.dll - отсутствует CLSID либо отсутствует интерфейс llnitDone 0
При выгрузке отчетности в 1С 7.7 программа ругается на v7plus.dll и указывает, что отсутствует интерфейс llritDone. Что делать? 1) Поудалять нафиг все v7plus.dll из каталогов ИБ и папок пользователей 2) Оставить только в bin каталоге и...
Журнал регистрации 0
Журнал регистрации относится к информационной базе и служит для сохранения информации о событиях, возникающих в процессе работы пользователей с данной информационной базой . Эта информация может быть важной с...
Запрет ввода новых документов в архивную базу. 0
Процедура глЗаполнитьШапку(Конт, Скопирован=0) Экспорт ... //Блокировка ввода новых документов СтатусВозврата(0); ... КонецПроцедуры Хотя наиболее правильно будет изменять права пользователей, т.к. необходимо будет...
Запуск 1С:Предприятия 7.7 под Windows 7 0
Установка 1С 7.7 под Windows 7 : Установщик 1С 7.7 является 16-битным приложением, а в Windows 7 отключена поддержка таких программ. Поэтому я взял другой установщик 1С, 32-битный(Ищите в интернет или спросите у Франчайзи). Запустил...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.