helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Как создать Двумерный или Многомерный массив?

Код 1C v 8.х
 ДвумерныйМассив = Новый Массив(2, 8); 

ДвумерныйМассив = Новый Массив;
МассивВторогоПорядка = Новый Массив(8);
ДвумерныйМассив.Добавить(МассивВторогоПорядка);
ДвумерныйМассив.Добавить(МассивВторогоПорядка);

Значение = ДвумерныйМассив[2][5];
Значение = ДвумерныйМассив.Получить(2).Получить(5);


Многомерный массив
Код 1C v 8.2 УП
 Массив = Новый Массив(3, 2);

Массив[0][0] = "Знач11";
Массив[0][1] = "Знач12";

Массив[1][0] = "Знач21";
Массив[1][1] = "Знач22";

Массив[2][0] = "Знач31";
Массив[2][1] = "Знач32";

// обход всех элементов через конструкцию Для Каждого
Для Каждого Строка Из Массив Цикл
Для Каждого Элемент Из Строка Цикл
Сообщить(Элемент);
КонецЦикла;
КонецЦикла;

// обход всех элементов через индекс
Для ИндексСтрока = 0 По Массив.Количество() - 1 Цикл
Для ИндексСтолбец = 0 По Массив[ИндексСтрока].Количество() - 1 Цикл
Сообщить(Массив[ИндексСтрока][ИндексСтолбец]);
КонецЦикла;
КонецЦикла;
КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 11087
 0 
Распечатать
Возможно, вас также заинтересует
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Google maps, поиск оптимального маршрута 2
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; *...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Быстрая загрузка данных большого размера файла Excel в многомерный Массив 0
// OldthiefXXX Перем СерверExcel; Процедура КнопкаВыполнитьНажатие(Кнопка) ФайлХЛС=СерверExcel.Application.Workbooks.Open(ДокументХЛС); КонечнаяСтрокаДанных=ФайлХЛС.ActiveSheet.UsedRange.Rows.Count; ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.