helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Как снять признак модифицированности?

Код 1C v 8.х
 Процедура НапечатанПриИзменении(Элемент)
Если Напечатан Тогда
КогдаНапечатан = ТекущаяДата();
Иначе
КогдаНапечатан = Дата(1,1,1);
КонецЕсли;
Если Модифицированность() Тогда
УстановитьПривилегированныйРежим(Истина);
ЭтотОбъект.Записать();
ЭтаФорма.Модифицированность=Ложь; //сбросили модифицированность
УстановитьПривилегированныйРежим(Ложь);
КонецЕсли;
КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 8073
 0 
Распечатать
Возможно, вас также заинтересует
Google maps, поиск оптимального маршрута 2
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; *...
Загрузка данных в 1С из PDF 1
В данной статье описан пример реализации загрузки данных накладных из PDF файлов для одного крупного Ритейла... И так у Нас есть несколько файлов в формате pdf, которые нам необходимо загрузить в 1С. Чтение PDF файлов из...
Как выбрать записи из регистра сведений? 1
//ВНИМАНИЕ !!! // В качестве полей для отбора могут задаваться измерения или реквизиты, для которых // в конфигураторе признак индексирования установлен в значение " Индексировать" или // установлен признак " Ведущее" ....
Как добавить подписи в отчет СКД? 0
Во многих организациях сформированные отчеты заверяют подписями. В данном примере я покажу как можно вывести подписи для типового отчета ЗУП Свод начислений. Для начала создадим макет в котором и разместим подписи,...
Как настроить автоматическую загрузку курсов валют при запуске программы 1С? 0
Курсы валют могут загружаться только при входе в программу какого-нибудь пользователя! Как в конфигурации Бухгалтерия 8 настроить автоматическую загрузку курсов валют при запуске программы? Необходимо открыть...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.