helpf.pro
Регистрация
 0 
Распечатать

Структура ~ Есть ли в структуре Значение элемента с ключом Контрагент?

Код 1C v 8.х
 
Если Структура.Свойство("Контрагент", ЗначениеЭлемента) Тогда
// Если Неопределено или Пустая то удалить
Если ЗначениеЭлемента = Неопределено ИЛИ ЗначениеЭлемента.Пустая() Тогда
Структура.Удалить("Контрагент");
КонецЕсли;
КонецЕсли;

// Обратиться к структуре можно так:
Структура.Контрагент
// или так:
Структура["Контрагент"]
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 10735
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
В чем разница между ОБЪЕДИНИТЬ и ОБЪЕДИНИТЬ ВСЕ в языке запросов 1С 2
Цитата из справки 1С: " По умолчанию при объединении запросов полностью одинаковые строки в результате запроса, сформированные РАЗНЫМИ запросами, заменяются одной . Если требуется, чтобы были оставлены разные...
Выборка, перебор документов 3
// Выборка документов за весь период Выборка = Документы.НачислениеОтпуска.Выбрать(); Пока Выборка.Следующий() Цикл //Модуль обработки КонецЦикла; // Выборка документов за период с Даты начала по Дата окончания ...
Посмотреть все результаты поиска похожих
Комментарии
E_Migachev
03.09.2010 16:15Комментарий: 2
E_Migachev
Да, Если Структура.Свойство("Контрагент", ЗначениеЭлемента) Тогда - это и есть проверка, а далее это уже как бы дополнение...
Mokey
03.09.2010 16:06Комментарий: 1
Mokey
По-моему, чтобы просто проверить (что вытекает из заголовка) - достаточно метода "Свойство" структуры, которая и вернёт булево. А в коде идёт проверка на заполненность свойства "Контрагент".
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.