helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Установить фильтр для оптимизации действий с регистром

Код 1C v 7.x
 // Пример 1
// Для регистра с измерениями «Товар», «Склад», «МОЛ» запись
Рег.УстановитьФильтр(Тов1, , );
// означает, что расчеты будут проводиться только по одному товару (Тов1), но по всем складам и МОЛам.
Рег = СоздатьОбъект("Регистр.Взаиморасчеты");
Рег.ВременныйРасчет();
Рег.УстановитьФильтр(Клиент, );
РассчитатьРегистрыНа(ДатаНачала);
Рег.ВыбратьДвиженияСОстатками(ДатаКонца);
Пока Рег.ПолучитьДвижение() = 1 Цикл
Прих = 0;
Расх = 0;
Если Рег.Приход = 1 Тогда
Прих = Рег.Долг;
Иначе
Расх = Рег.Долг;
КонецЕсли;
ТекущееСальдо = Рег.Остаток(Клиент, "Задолженность");
Док = Рег.ТекущийДокумент();
Таб.ВывестиСекцию("Документ");
КонецЦикла;

// Пример 2
РегТовары = СоздатьОбъект("Регистр.Товары");
//выбрать все движения по данному складу за период
РегТовары.УстановитьФильтр(,ТекСклад);
РегТовары.ВыбратьДвижения(ДатаНач, ДатаКон);
Пока РегТовары.ПолучитьДвижение()=1 Цикл
//... код
КонецЦикла;

// Пример 3
РегТовары = СоздатьОбъект("Регистр.Товары");
//выбрать все товары на данном складе
РегТовары.УстановитьФильтр(,ТекСклад);
РегТовары.ВыбратьИтоги();
Пока РегТовары.ПолучитьИтог()=1 Цикл
//... код
КонецЦикла;
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 5862
 0 
Распечатать
Возможно, вас также заинтересует
ЗначениеВСтрокуВнутр / ЗначениеИзСтрокиВнутр 1
Эту статью я посвящаю двум процедурам ЗначениеВСтрокуВнутр и ЗначениеИзСтрокиВнутр . Они являются полным «антиподом действий» друг другу, а разработчики 1с предприятия отнесли их в раздел «Процедуры и функции...
Как конвертировать БД 1С SQL в БД 1с обычную dbf? 2
Последовательность действий такая: 1. Создать новую базу 1С. (Создать пустой каталог, скопировать в него папку ExtForms, в старотовом окне 1С нажать кнопку добавить, написать название базы и путь к только что созданному...
Как конвертировать БД 1с обычную dbf в БД 1С SQL? 0
Последовательность действий такая (подразумевается что 1С версия для sql и сам ms sql server уже установлены): 1. Создать новую базу 1С, указать что это база SQL. 2. Создать новую базу данных SQL. При этом Вы прописываете, где будет...
Параметры, ключи запуска 1Сv7 из командной строки 0
Режим предназначен для выполнения конфигуратором административных функций без участия пользователя. Данный режим применяется в специальных случаях. Например, с его помощью можно организовать специальный ярлык на...
Периодическое выполнение кода с заданным интервалом времени - ОбработкаОжидания() 0
ПодключитьОбработчикОжидания( ИмяПроцедуры , Интервал , Однократно ) Параметры: ИмяПроцедуры (обязательный) Тип: Строка. Имя процедуры, подключаемой в качестве обработчика ожидания. Интервал (обязательный) Тип:...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.