helpf.pro
Регистрация
 0 
Распечатать

1С 7.x : Как получить Имя Пользователя?

Код 1C v 8.2 УП
 &НаКлиенте
Процедура СообщитьИмяПользователя(Команда)
// Вставить содержимое обработчика.
Сообщить(ПолучитьПользователя());

КонецПроцедуры

&НаСервере
Функция ПолучитьПользователя()
Перем ВыбПользователь;
ВыбПользователь = ПользователиИнформационнойБазы.ТекущийПользователь();
Возврат ВыбПользователь.Имя;
КонецФункции;

// или так:
Сообщить(ИмяПользователя());
Сообщить(ПолноеИмяПользователя());



Код 1C v 8.х
 ИмяПользователя = ИмяПользователя();    
Если ПустаяСтрока(ИмяПользователя) Тогда
// пользователь не авторизовался
ИмяПользователя = "НеАвторизован";
Иначе
ИмяПользователя = ПолноеИмяПользователя();
КонецЕсли;



Код 1C v 7.x
 Сообщить(ИмяПользователя())
// Сообщит: ПупкинВася

Сообщить(ПолноеИмяПользователя())
// Сообщит: Пупкин Василий Петрович
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 13788
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 21
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Быстрая выгрузка отчетов в Excel, наложение Фильта и отображение ярлыка 0
Вместо Таб.Показать() используем глобальную функцию - и отчет показывается сразу в Excel в удобоваримом виде - с форматированием колонок по ширине, автофильтром и ярлычками листов Процедура...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.